Jump to content
Sports Interactive Community
stevemc

Bidstack Advertising Board

Recommended Posts

Hi, since updating to the latest update, two video adboards have started appearing in every game regardless of competition:

One is Bidstack:

vjpd.png

And I'm not sure what this one is:

169p0r5.png

 

Anyone know how I can disable them so they stop showing? I presume they've been coded in?

 

EDIT: Presume it has something to do with this? https://www.linkedin.com/pulse/bidstack-exclusive-pitchside-advertising-platform-football-draper

Edited by stevemc

Share this post


Link to post
Share on other sites

Found a simple work around for this, which is to turn off the WiFi.

Is there another way though?

Share this post


Link to post
Share on other sites

its called SI dicking about with the game and ruining it like they always do.Reading about it Miles  said it was a brill idea so company's can advertise through FM. So expect more unwanted ad boards in future just to ruin the game even more.

 

Share this post


Link to post
Share on other sites

It ruins emersion for me though, I don't want to see targeted advertising boards appearing during Champions League matches, for example, it ruins the reality of it all. Just seems like a money-spinner for SI.

Edited by stevemc

Share this post


Link to post
Share on other sites

Correct mate It just goes to show Si don't give a toss about us people who pay for the game and spend hours making graphics to make the game look better because Si can't be arsed making them

Share this post


Link to post
Share on other sites

Adboards have been in the game for years, dynamic internet based ones can be removed in exactly the same manor as the static ones, if you have a look through the forum (or on fansites) there are several threads around about editing the adboards.

Share this post


Link to post
Share on other sites

Nope your wrong Michael The file is in the aps folder every time you delete the file as soon as you load your game the file re appears.Even taken it out of the simatch uncompressed folder using archiver and still returns back in game 

Share this post


Link to post
Share on other sites
12 minutes ago, michaeltmurrayuk said:

Adboards have been in the game for years, dynamic internet based ones can be removed in exactly the same manor as the static ones, if you have a look through the forum (or on fansites) there are several threads around about editing the adboards.

I know adboards have been around because I have made my own, but this is the first time I've come across this Bidstack internet based adboard, and I can't find an answer anywhere on the internet so far about disabling it...

As I say, turning off the WifI must stop it communicating with your game, and doesn't load them into the game - but there must be another way?

Edited by stevemc

Share this post


Link to post
Share on other sites
3 minutes ago, handy500 said:

Nope your wrong Michael The file is in the aps folder every time you delete the file as soon as you load your game the file re appears.Even taken it out of the simatch uncompressed folder using archiver and still returns back in game 

Out of curiosity, what is the file name?

Share this post


Link to post
Share on other sites

There is no need to delete the default files, custom adboard files automatically override the default ones - my custom files are working perfectly fine.

If for whatever reason your ones aren't working then check the config file - there is an option at the bottom to disable dynamic ads for certain teams/comps just add your ids there, or you can just remove the lines corresponding to the default/dynamic ads from the file, or if you don't want to mess around with the files if turning off your internet works then just block FM from accessing the internet in your firewall and that should do the same.

Share this post


Link to post
Share on other sites

My custom adboards are also working fine, none as missing, it’s that since the last update Bidstack are adding in advertising boards (in all matches and competitions) in and around my custom ones, and I don’t want that to happen.

 

I can’t see it being in the config file, because the config file was set by me and wouldn’t be updated as part of an SI update.

Edited by stevemc

Share this post


Link to post
Share on other sites

If they are being added in and around your custom adds then it sounds like you haven't declared enough adds for the comp so it is filling in the gaps with the default ones, increasing the fill size should stop it from happening, I've increased mine from the default of 7 to 99.

Share this post


Link to post
Share on other sites

OK, I'll take a look at adding more in then, but these two Bidstack Ads record in between the 1st and 2nd of my eight video adboards for the EPL - funny that this has never been an issue before this latest update - constantly tinkering with the game!

Share this post


Link to post
Share on other sites
10 hours ago, michaeltmurrayuk said:

If they are being added in and around your custom adds then it sounds like you haven't declared enough adds for the comp so it is filling in the gaps with the default ones, increasing the fill size should stop it from happening, I've increased mine from the default of 7 to 99.

Michael i have 14 ad boards in my Liverpool game and they still show up its nothing that we are doing wrong and its not are config file at all everything was perfect until si decided to put these stupid ad boards in the game there is no need for them at all SI can not leave anything alone they have to cock something up all the time when are they ever going to learn to leave things a lone

Share this post


Link to post
Share on other sites

Just tried this with more code in the config to record more video ads, and it's made no difference. The game still records Bidstack adboards into game around the pitch in various competitions, so for now, until there is a resolution, I'll turn the WiFi off so Bidstack cannot communicate to my laptop. 

Share this post


Link to post
Share on other sites

Again there not showing in my game for comps I've replaced the boards in, so it's perfectly possible to override them - where are you placing your video ads are you repacking them into the simatchviewer_uncompressed fmf file or just creating and placing them in the simatchviewer_uncompressed folder? - if you just place the ones you want in the folder (rather than repacking the fmf file) then they should stop the default/dynamic ones being used (you may also need to extract and copy over the font files from that fmf file to stop you losing the shirt numbers).

Share this post


Link to post
Share on other sites

That's the view inside my folder, I don't re-pack the simatchviewer_uncompressed folder. Again, I've done nothing different since before the update, so it's something in the latest update.

xepz7t.png

I have the font too, that all works fine.

I've Googled this, and on some other fan sites, people are having the same issues, so it's not just me.

Edited by stevemc

Share this post


Link to post
Share on other sites

@stevemc What pack are you using? I assume you are using the sortitoutsi one (club or non-club one?) does it appear randomly or always after a certain ad, does it appear in live matches or when watching goals from a previous match, does it appear just in your matches or any match? If it only appears for your team who are you managing? Also are the other people having problems on a MAC aswell?

Does it still appear if you try this basic pack I've attached

video_ads.zip

Just includes a vid ad for Prem and Champions league, showing the logo text in different colours - place the mine folder in the \simatchviewer_uncompressed\videos\hd\video_ads\ folder and place in the xml file in the main ads folder replacing the existing file (move the existing file to somewhere like the desktop out of the way - you can leave the vids and graphics alone).

Share this post


Link to post
Share on other sites

I've logged off for now, but I'll try these tomorrow and report back!

Share this post


Link to post
Share on other sites

Right in your config file you need to look for this   <record id="deon" size="7" />    <!-- use the default ads 7 times to get more than 50 cells -->     change the size="7" to "99"    it will then stop Bidstack video ad from showing up in your game  

(Happy Days)

Share this post


Link to post
Share on other sites
4 hours ago, Jeff44 said:

Right in your config file you need to look for this   <record id="deon" size="7" />    <!-- use the default ads 7 times to get more than 50 cells -->     change the size="7" to "99"    it will then stop Bidstack video ad from showing up in your game  

(Happy Days)

Thanks, I'll test this too.

Edited by stevemc

Share this post


Link to post
Share on other sites
20 hours ago, michaeltmurrayuk said:

@stevemc What pack are you using? I assume you are using the sortitoutsi one (club or non-club one?) does it appear randomly or always after a certain ad, does it appear in live matches or when watching goals from a previous match, does it appear just in your matches or any match? If it only appears for your team who are you managing? Also are the other people having problems on a MAC aswell?

Does it still appear if you try this basic pack I've attached

video_ads.zip

Just includes a vid ad for Prem and Champions league, showing the logo text in different colours - place the mine folder in the \simatchviewer_uncompressed\videos\hd\video_ads\ folder and place in the xml file in the main ads folder replacing the existing file (move the existing file to somewhere like the desktop out of the way - you can leave the vids and graphics alone).

OK, I've tried those and they do work.

Answers to your other questions, I'm using the sortitoutsi pack (non-club), but I've adapted it myself. Always appear after the first video advert in the pack records in live matches. I'm not about it being Mac specific.

I will now try the change the size="7" to "99" and see if that fixes my issue.

 

Share this post


Link to post
Share on other sites

I've changed change the size="7" to "99" and it seems to have worked for now, thanks all!

Share this post


Link to post
Share on other sites
1 hour ago, stevemc said:

I've changed change the size="7" to "99" and it seems to have worked for now, thanks all!

Ive played 4 games this afternoon and had no problems since i done it

Share this post


Link to post
Share on other sites

I played about 10 games last night and not noticed any BidStack adboards :brock:

Share this post


Link to post
Share on other sites
5 hours ago, stevemc said:

I played about 10 games last night and not noticed any BidStack adboards :brock:

yea touch wood you wont see them again

Share this post


Link to post
Share on other sites
On ‎4‎/‎04‎/‎2018 at 08:33, michaeltmurrayuk said:

@stevemc What pack are you using? I assume you are using the sortitoutsi one (club or non-club one?) does it appear randomly or always after a certain ad, does it appear in live matches or when watching goals from a previous match, does it appear just in your matches or any match? If it only appears for your team who are you managing? Also are the other people having problems on a MAC aswell?

Does it still appear if you try this basic pack I've attached

video_ads.zip

Just includes a vid ad for Prem and Champions league, showing the logo text in different colours - place the mine folder in the \simatchviewer_uncompressed\videos\hd\video_ads\ folder and place in the xml file in the main ads folder replacing the existing file (move the existing file to somewhere like the desktop out of the way - you can leave the vids and graphics alone).

Hi Michael, who created the video adboards? They are very good, apart from the scaling.

Share this post


Link to post
Share on other sites
14 hours ago, jeff roberts said:

Hi Michael, who created the video adboards? They are very good, apart from the scaling.

I did, they were just some rough conversions of my static ones into videos to test out how the vid ads worked in FM17.

Share this post


Link to post
Share on other sites

It would appear this rather annoying feature is back on FM19, which wasn't an issue on the beta.

Advertising boards that I don't want to see, are recording themselves in game pitch side, I presume via Bidstack - meaning the adboards I've created no longer show. :mad:

• I've toggled "targeting advertising" to no in the preferences but it's made no difference.

• The fix from FM18 of  changing <record id="deon" size="7" /> to <record id="deon" size="99" /> doesn't appear to work either.

Anyone found a fix to stop this happening yet?

Share this post


Link to post
Share on other sites

Hi Steve, had the same problem and did the same as you with a similar result. However, today all those ads have gone and it is just my adboards, which I am rather pleased about. Not sure what changed and only suggestion I have is make sure you version is up to date and restart the game.

Share this post


Link to post
Share on other sites
13 hours ago, jeff roberts said:

Hi Steve, had the same problem and did the same as you with a similar result. However, today all those ads have gone and it is just my adboards, which I am rather pleased about. Not sure what changed and only suggestion I have is make sure you version is up to date and restart the game.

Done all of that, but no joy. I'm not entirely sure how it pulls the adverts into the game, and when it pulls them in as it's a mixed bag at the moment. Frustrating, as I just don't want them there at all.

Edited by stevemc

Share this post


Link to post
Share on other sites

I did figure out that teams that we haven't done adboards for i.e. Cardiff the game adds its own rather than having blank adboards

Share this post


Link to post
Share on other sites
On 04/11/2018 at 01:42, jeff roberts said:

Hi Steve, had the same problem and did the same as you with a similar result. However, today all those ads have gone and it is just my adboards, which I am rather pleased about. Not sure what changed and only suggestion I have is make sure you version is up to date and restart the game.

Which adboards pack do you use?

Share this post


Link to post
Share on other sites
On 04/11/2018 at 00:42, jeff roberts said:

Hi Steve, had the same problem and did the same as you with a similar result. However, today all those ads have gone and it is just my adboards, which I am rather pleased about. Not sure what changed and only suggestion I have is make sure you version is up to date and restart the game.

Your version isn't working for me I'm afraid, Bidstack boards everythere. The whole thing just appears to be pot luck.

Share this post


Link to post
Share on other sites
1 hour ago, White Flag said:

Your version isn't working for me I'm afraid, Bidstack boards everythere. The whole thing just appears to be pot luck.

Since I've turned Steam onto "Offline Mode" I've played 4 matches and not seen one Bidstack targeted adboard. I'll keep my eye on it, but it does seem very random when the record in.

Share this post


Link to post
Share on other sites

Can't get the custom adboards working on my Mac. Whatever I do.. I only see the default ads (Bidstack, Prostate Cancer UK, etc.) or only black adboards. Anyone who got this working on a Mac? Or does it only work on Windows for FM 2019 right now?

Targeted Ads are set to NO in preferences.

Edited by Rivanov

Share this post


Link to post
Share on other sites
6 minutes ago, Rivanov said:

Can't get the custom adboards working on my Mac. Whatever I do.. I only see the default ads (Bidstack, Prostate Cancer UK, etc.) or only black adboards. Anyone who got this working on a Mac? Or does it only work on Windows for FM 2019 right now?

Targeted Ads are set to NO in preferences.

I'm on a Mac, and have it working.

 

Video's here:

‎⁨Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨name ▸ ⁨Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨Steam⁩ ▸ ⁨steamapps⁩ ▸ ⁨common⁩ ▸ ⁨Football Manager 2019⁩ ▸ ⁨data⁩ ▸ ⁨simatchviewer_uncompressed⁩ ▸ ⁨videos⁩ ▸ ⁨sd⁩ ▸ ⁨video_ads⁩

 

XML here:

‎⁨Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨name ▸ ⁨Documents⁩ ▸ ⁨Sports Interactive⁩ ▸ ⁨Football Manager 2019⁩ ▸ ⁨ads⁩ ▸ ⁨fm.xml

 

Static ads here:

‎⁨Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨name ▸ ⁨Documents⁩ ▸ ⁨Sports Interactive⁩ ▸ ⁨Football Manager 2019⁩ ▸ ⁨graphics⁩ ▸ ⁨pictures⁩ ▸ ⁨ads⁩

Edited by stevemc

Share this post


Link to post
Share on other sites
32 minutes ago, stevemc said:

Since I've turned Steam onto "Offline Mode" I've played 4 matches and not seen one Bidstack targeted adboard. I'll keep my eye on it, but it does seem very random when the record in.

Scrap that, they've just started showing again so that didn't work!

Share this post


Link to post
Share on other sites

What I'm finding is, If you turn the Wifi off on your laptop, then custom video adboards work, but, it records the first video from the XML file, and loops it for an extended time so sometimes during a game you'll not see the other video ads, so in the case of the EPL below, it records the top line (Sky) for an extended time compared to FM18:

Quote

<!-- English Premiership ads -->


        <record id="1262" path="video_ads/england/premiership/sky" animated="true"/>
        <record id="1263" path="video_ads/england/generic/sportpesa" animated="true"/>
        <record id="1264" path="video_ads/england/generic/bt" animated="true"/>
        <record id="1265" path="video_ads/generic/bet365" animated="true"/>
        <record id="1266" path="video_ads/england/premiership/epl" animated="true"/>
        <record id="1267" path="video_ads/england/generic/apollo" animated="true"/>
        <record id="1268" path="video_ads/england/generic/vitality" animated="true"/>
        <record id="1269" path="video_ads/generic/carlsberg" animated="true"/>
        <record id="1270" path="video_ads/england/generic/bd" animated="true"/>
        <record id="1271" path="video_ads/england/generic/tempobet" animated="true"/>
        <record id="2095" path="pictures/ads/europe/england/premiership/prem blue"/>
        <record id="2096" path="pictures/ads/europe/england/premiership/prem green"/>
        <record id="2097" path="pictures/ads/europe/england/premiership/prem yellow"/>
        <record id="2098" path="pictures/ads/europe/england/premiership/prem pink"/>

As you can see in the screenshot below, the static adboards are fine, but the video ad is the first line of the XML (Sky), it took until the 41st minute watching the game on FULL to start recording the second line of the XML in:

25ov5gg.png

That was all whilst having everything in this file set to "FALSE":

‎⁨Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨name ▸ ⁨Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨Sports Interactive⁩ ▸ ⁨Football Manager 2019⁩ ▸ ⁨Preferences⁩ ▸ ⁨version 3⁩ ▸ ⁨channels⁩ ▸ ⁨BIDSTACK_CHANNEL.xml

I presume having the internet off on your laptop stops Bidstack being able to communicate with the game to record their adboards in?

Edited by stevemc

Share this post


Link to post
Share on other sites
2 hours ago, stevemc said:

I'm on a Mac, and have it working.

 

Video's here:

‎⁨Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨name ▸ ⁨Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨Steam⁩ ▸ ⁨steamapps⁩ ▸ ⁨common⁩ ▸ ⁨Football Manager 2019⁩ ▸ ⁨data⁩ ▸ ⁨simatchviewer_uncompressed⁩ ▸ ⁨videos⁩ ▸ ⁨sd⁩ ▸ ⁨video_ads⁩

 

XML here:

‎⁨Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨name ▸ ⁨Documents⁩ ▸ ⁨Sports Interactive⁩ ▸ ⁨Football Manager 2019⁩ ▸ ⁨ads⁩ ▸ ⁨fm.xml

 

Static ads here:

‎⁨Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨name ▸ ⁨Documents⁩ ▸ ⁨Sports Interactive⁩ ▸ ⁨Football Manager 2019⁩ ▸ ⁨graphics⁩ ▸ ⁨pictures⁩ ▸ ⁨ads⁩

Using the exact same paths just as in 2018.. But with no positive results. Even uninstalled FM and reinstalled the game.

Do I need to leave the simatchviewer_uncompressed.fmf file in the data folder? And you only have the SD videos? No HD folder?

Share this post


Link to post
Share on other sites
11 minutes ago, Rivanov said:

Using the exact same paths just as in 2018.. But with no positive results. Even uninstalled FM and reinstalled the game.

Do I need to leave the simatchviewer_uncompressed.fmf file in the data folder? And you only have the SD videos? No HD folder?

I moved everything over from FM18 to FM19 and didn't change anything. I just renamed the HD folder to SD because my graphics card only reads SD.

Delete the simatchviewer_uncompressed.fmf file - the folder should look like this:

2wd3nlj.png

 

Obviously then in preferences, make sure it looks like this:

33jk8ie.png

Edited by stevemc

Share this post


Link to post
Share on other sites

Guys If you go to your prerences and select no on the targeted advertisng then clear cache and reload skin that should stop all the bidstack ads

Football Manager 2019_ Preferences Overview.png

Share this post


Link to post
Share on other sites
17 minutes ago, handy500 said:

Guys If you go to your prerences and select no on the targeted advertisng then clear cache and reload skin that should stop all the bidstack ads

Football Manager 2019_ Preferences Overview.png

Tried this, doesn't work unfortunately, they return randomly over time.

As I say, so far the only workaround I've had any joy with is turning the WiFi off on my laptop but it needs extensive testing.

Share this post


Link to post
Share on other sites
7 hours ago, stevemc said:

I moved everything over from FM18 to FM19 and didn't change anything. I just renamed the HD folder to SD because my graphics card only reads SD.

Delete the simatchviewer_uncompressed.fmf file - the folder should look like this:

2wd3nlj.png

 

Obviously then in preferences, make sure it looks like this:

33jk8ie.png

Which adboard pack do you use?

Share this post


Link to post
Share on other sites
14 hours ago, michaeltmurrayuk said:

If the Internet Ads are showing whilst you have targetted ads turned off then it is worth raising the issue in the bugs forum.

Done, thanks - we'll see what the response is.

 

Share this post


Link to post
Share on other sites
9 hours ago, Rivanov said:

Which adboard pack do you use?

It's a couple of different ones, plus a few of my own that I've put together over the last 2 years.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...