Jump to content
Sports Interactive Community
slamzone

2D engine broken after update

Recommended Posts

The 2D engine isn't working anymore after the update when I set the highlights to "key only" and use a fast clock. The game freezes and doesn't move until I hit "pause" and "continue" to move the clock, but it only goes forward a few seconds.

So basically an entire feature of the game is broken now.

Anyone know what to do about this? Started happening after the update. I really wish I didn't update this game :(

Share this post


Link to post
Share on other sites

Same here. I'm running it via PlayOnMac, so had wondered if that was the source of the issue, but perhaps it is just the engine in general. I can leave it going in the background and it will eventually advance, but it's a pretty slow process, and a lot less organic than it was prior to the end of EA.

Share this post


Link to post
Share on other sites

slamzone, are you also running the game on a Mac ?

I've played a few games on the 2D just today and it works fine for me on all the highlight/clock/action settings.

Share this post


Link to post
Share on other sites

I cant play after the update either, before i used to play with the clockspeed at medium and no 2D Engine. After the update the clock gets stuck or moving really slow.

I`m not using mac

Share this post


Link to post
Share on other sites
slamzone, are you also running the game on a Mac ?

I've played a few games on the 2D just today and it works fine for me on all the highlight/clock/action settings.

Not on Mac.

The clock does move but it goes very slow. Before the update the game would fast forward to key moments very quickly, now the simulation is very laggy and takes much longer than before, defeats the purpose of running with key highlights since it takes so long.

Share this post


Link to post
Share on other sites

The clock movement is extremely slow between highlights. I run with extended highlights and when it used to zip between the action sequences before it now crawls - sometimes close to real time. 60-70% of the time spent watching a game is spent watching a frozen ice and a slowly crawling clock.

Share this post


Link to post
Share on other sites

I did some checking and this is resolution dependent. The problem is severe when running in 1440x900 but almost gone when going back to 1024x768 which really doesn't make any sense, there should be no difference in rendering a clock - everything else is frozen.

Share this post


Link to post
Share on other sites
The clock movement is extremely slow between highlights. I run with extended highlights and when it used to zip between the action sequences before it now crawls - sometimes close to real time. 60-70% of the time spent watching a game is spent watching a frozen ice and a slowly crawling clock.

Yes this is exactly the problem. It doesn't seem to change no matter what screen resolution I try though.

Share this post


Link to post
Share on other sites
Yes this is exactly the problem. It doesn't seem to change no matter what screen resolution I try though.

have the same one...the clock is going so slow, even if I have them set on Fast...before the update the clock was going okay, no matter which settings I used.

Share this post


Link to post
Share on other sites
I did some checking and this is resolution dependent. The problem is severe when running in 1440x900 but almost gone when going back to 1024x768 which really doesn't make any sense, there should be no difference in rendering a clock - everything else is frozen.

I switched back to 1024x768 and it made no difference. I'll try closing/reopening EHM, though, and see if that makes any difference.

Share this post


Link to post
Share on other sites
I switched back to 1024x768 and it made no difference. I'll try closing/reopening EHM, though, and see if that makes any difference.

It is very noticeable between resolutions for me. It's still slower than it used to be on 1024x768 but not by very much - on higher resolutions it's really slow but it never stops totally.

I think I can detect some subtle changes in how players move and behave, with more detail and less stereotype in their actions. If this is true (and not my imagination) it could explain "fast forward" not being able to cope but that can't explain differences between resolutions.

Share this post


Link to post
Share on other sites

I'm looking into adjusting the clock speeds between highlights and adjusting the related refresh rates. Thanks for the feedback.

Share this post


Link to post
Share on other sites

Just some further information about your settings, what are you using during the 2D for these settings:

- clock speed

- action speed

Share this post


Link to post
Share on other sites
Just some further information about your settings, what are you using during the 2D for these settings:

- clock speed

- action speed

Hi Riz,

I'm using clock speed - FAST

Action speed - NORMAL

Highlights - KEY ONLY

It worked fine before the update, if you can find a way to get it back to how it was I'll give you the biggest e-hug ever. Thank you for your help.

Share this post


Link to post
Share on other sites
Just some further information about your settings, what are you using during the 2D for these settings:

- clock speed

- action speed

Extended Highlights

Medium Clock Speed

Slow Action Speed

Share this post


Link to post
Share on other sites
Just some further information about your settings, what are you using during the 2D for these settings:

- clock speed

- action speed

Clock speed - fast

Action speed - normal

Share this post


Link to post
Share on other sites
I'm looking into adjusting the clock speeds between highlights and adjusting the related refresh rates. Thanks for the feedback.

If you can let us know what's going on it'll help. As I said earlier I'm definitely seeing more detail in this 2D than in Early Access (or EHM2007). There is more information presented to us and the action is less "cartoon-like" than before.

If you have pumped up the level of realism in the simulation this shouldn't be kept a secret.

Share this post


Link to post
Share on other sites
If you can let us know what's going on it'll help. As I said earlier I'm definitely seeing more detail in this 2D than in Early Access (or EHM2007). There is more information presented to us and the action is less "cartoon-like" than before.

If you have pumped up the level of realism in the simulation this shouldn't be kept a secret.

The action itself is being simulated exactly as in the last Early Access builds. The only difference is that the screens are now rendered with DirectX so on some systems this may have caused changes in the refresh rates both between highlights and during highlights, depending on the system.

Share this post


Link to post
Share on other sites

I have the same problem Riz,

Key

Fast

Normal

But also have tried in other areas and it is not working the way it should....not smooth. All chunky and horrible, Makes it horrid to watch and play.

Share this post


Link to post
Share on other sites
slamzone, dbfinch... I've sent you guys PM's here on the forums about a possible fix. Please check your inboxes.

Having the same issue Riz, any ideas?

Share this post


Link to post
Share on other sites
Hi Riz,

I'm using clock speed - FAST

Action speed - NORMAL

Highlights - KEY ONLY

It worked fine before the update, if you can find a way to get it back to how it was I'll give you the biggest e-hug ever. Thank you for your help.

Using same as you,,,

Share this post


Link to post
Share on other sites

Great game, thank`s for that! Would really appreciate if this problem could be fixed, either in an update or instructions on how to sort it myself. Cheers!

Share this post


Link to post
Share on other sites

After testing the 1.0.2 update the clock-rate between highlights is very much better but during highlights the movement of the players is not nearly as smooth as it was with the earlier versions. Movement during highlights have also sped up and is too fast (on slow action setting) and when setting action to very slow the jerkiness of player movement is very apparent.

Tested on 1024x768 (will try higher resolution for next game)

Medium clock speed

Slow (and very slow) action speed

Extended highlights

Share this post


Link to post
Share on other sites

The update really made the game playable again.

Now i can play without wathing any highlights and still have the time to pause whenever i want.

Tumbs up!

Share this post


Link to post
Share on other sites

After changing resolution to 1440x900 the clock-speed between highlights is much slower. Setting clock speed to Fast equals a setting of Medioum on 1024x768 in appearance. The player movement is also jerkier here too. The detail level of what I see is much lower and not as granular as with version 1.0.1.

The "In-between Highlights" speed is very much better now but the action itself is a big step backwards both in the way it looks and in how the players move.

Share this post


Link to post
Share on other sites

Highlights: None

Clock Speed: Fast

Acion speed: Fast forward

It was fine before the latest update. However, the clock speed has slowed down significally with this update.

Share this post


Link to post
Share on other sites

The clock works better after the update but not nearly as smooth/fast as before 1.0.1. It`s playable but barely. Thank`s for the hard work though!

Share this post


Link to post
Share on other sites

The "In-between Highlights" speed is very much better now but the action itself is a big step backwards both in the way it looks and in how the players move.

The player movement between the highlights was not actually adjusted in the last update, only the clock updates between highlights. The only changes to the actual highlights were very small changes to the updates on slow/very slow mode.

Share this post


Link to post
Share on other sites
The player movement between the highlights was not actually adjusted in the last update, only the clock updates between highlights. The only changes to the actual highlights were very small changes to the updates on slow/very slow mode.

That's not the way it turns out in reality. (I do run in slow action mode - anything higher is like watching an old silent movie that's speeding.)

Compared with version 1.0.1 (and the original release) this version 1.0.2 shows player movement stuttering and not nearly as smooth as before. With action speed set to very slow it is very apparent - the players stutter on the ice (3 mm steps to every refresh, roughly). With version 1.0.1 the player movement was smooth enough to fool the eye completely. This makes a distinct difference when it comes to the ability to see deking moves and stick moves which are very much less visible now. The appearance of the figurines themselves is also now very much changed (duller, no shadow effects etc.).

If it was up to me I'd rather live with the slow clock in version 1.0.1 and have the added details. At least as long as there is no advantage to running a higher resolution than 1024x768. If (when) you decide to better utilize the higher resolutions this will of course change.

PS. If it's any help I'm on a GTX465 and DX11

Share this post


Link to post
Share on other sites

Hello, I have still big problem with speed of the game match sim. When it was just Early access, the game was pretty fast, but after some updates, it is horribly slow. Can you please tell me, what to do?

(I tried to reinstall the game too. I have the newest 1.0.2 version)

Please help! :-(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...