Jump to content
Sports Interactive Community
Sign in to follow this  
Lottario

[1.2.2] Disk Space and Disk I/O Errors Make the Game Unplayable

Recommended Posts

Hi all,

When I played EHM back in early access, everything worked fine. I've been trying to pick it up to play again now, but the problem is I keep getting the errors below:

Disk_IO_Error.pngDisk_Space_Error.png

I can click through these errors and keep playing, but by mid-October of a season, I'll have to click through 50+ to be able to sim a day, which essentially makes the game unplayable. These don't happen every sim day, but they do happen fairly often. I can also get them when creating a game (as seen in the screenshots above), but I've found that is at least somewhat dependent on the size I select for the database (it happens more often if I select a larger one, and if I have more leagues set to view only/enhanced).

I've tried uninstalling and reinstalling, running as admin, installing as admin, changing the folder/file permissions of the saved games, running a disk check on my computer (and fixing errors), changing database size, changing the database I use for the game, and nothing seems to fix it. I've got ~2/3s of my hard drive available, so disk space isn't an issue either. I've tried to Google the problem, and I've found a few people that have the same issue, but no solutions.

I asked on the Blue Line forums here, where it was suggested to uncheck "Verify Available Disk Space" in preferences, but that didn't seem to help.

I'm happy to upload a save, but I don't know at what point the save file would be most helpful (especially since this error can occur before even creating the save, and I can't predict when simming a day will cause it).

Share this post


Link to post
Share on other sites

You have a hardware problem.

Either your hard drive or your memory is causing data corruption when writing to disk.

Run chkdsk and check the hard drive for errors and download memtest+ and check your RAM.

The error your seeing is caused by data being corrupted. In more than 90% of cases this will be due to either bad sectors on your drive or bad RAM corrupting the data during the write process.

Share this post


Link to post
Share on other sites

Hi Ivan,

Thanks for your reply. I ran chkdsk a couple nights ago to try to fix the problem - it found/fixed one bad sector, but I still get these errors. I just ran memtest+ and it didn't show any issues either. If the problem was the HDD or RAM, wouldn't I also be seeing problems in other applications? I only have issues running EHM.

 

EDIT: I just tried installing on a different hard drive (I've got two in this computer), with the game data also saved to that drive - still get the same errors.

Edited by Lottario

Share this post


Link to post
Share on other sites

Are you talking about the same saved game or a new one? An already corrupted database cannot be fixed.

There is an option under preferences "save safely" that should be checked. I'm not sure exactly what this option does but it cannot hurt.

A HDD error will affect everything that is written to that part of the drive and if you're overwriting the same save then you'll get multiple errors in that file, new errors for every write. A RAM error will mess with writes differently depending on the type of data you're writing, this is a compressed database and those are much more sensitive than a picture or a word document. It is not a given that a RAM error will show up during ordinary usage.

If you still get this problem with a new game then you have to look at other things.

 

Share this post


Link to post
Share on other sites

Hi Ivan and Asher,

I experience this issue with every game I create (I create a new game in each attempt to correct it - I can't seem to get past about mid-October before these errors make the game unplayable). I do have save safely checked, and also save compressed. I seem to be able to save and load games fine - I never get these errors when saving the game, and if I load one that I've seen these errors in before, all of the data seems correct.

As Asher mentioned, I also sometimes get these errors when initializing a new game (this seems to depend both on the database I select, and the number of leagues I have set to Enhanced or View-Only), which I believe is before a saved game is even created.

Share this post


Link to post
Share on other sites
13 hours ago, Asher413 said:

That's a start new game screen, so it's not a corrupted save file.

Hmm... What OS are you using?

It could be caused by incorrect file permissions. Such issues have been reported by people that have upgraded a windows 8 to windows 10. File permission errors have also been reported by people that have moved "My Documents" folders manually (and breaking windows linking).

If it's not that then I'm out of ideas, sorry.

PS. There's an oddity with windows user accounts (SAM) in that an administrator account will have a different SAM even if it has the same account name as a user account and thus not having access to the files of the user account. If you installed as an admin but placed the files in folders where the user has access then running as admin could cause the files to be unreachable.

Share this post


Link to post
Share on other sites

I'm on Windows 7, so no issues with upgrading to 10. And I've uninstalled and removed all related files, and then reinstalled several times, so that should fix any file permission issues anyways (unless they're set up wrong by default for some reason).

I haven't moved the My Documents folder, so that shouldn't be it. On my most recent install to try to find these issues, I changed the default User Data folder location away from My Documents anyways (onto that second hard drive I mentioned above), but that doesn't seem to have solved it.

I've manually given all user groups on my computer all permissions to any of the EHM files (both Steam and the User Data folder), but that doesn't seem to have helped at all.

I've tried both installing as admin and just installing regularly, and running as admin both ways - still get these errors.

Share this post


Link to post
Share on other sites

Then the only other thing I can think of is if your download of the game is corrupted. If you've used the same download for all installs then that could be the cause. If not then I have to give up. Sorry.

Share this post


Link to post
Share on other sites

I've redownloaded for every fresh install, so unfortunately thats not it either. Its too bad I can't go back to an EA version, when I had the game working.

Thanks for trying to help, sorry my computer seems to want to make things difficult.

Share this post


Link to post
Share on other sites

One last try.

You say you uninstalled then reinstalled. Did you delete all config files and directories after the uninstall? The uninstall doesn't delete everything, it keeps settings for the next install. There are instructions for deleting everything left over elsewhere on this forum if that's the case.

Share this post


Link to post
Share on other sites

I've cleared out the User Data folder from My Documents, and the Sports Interactive folder under AppData - am I missing any? Deleting both of those before reinstalling doesn't seem to help, unfortunately (I'm pretty sure I've tried before, but I tried again now and it doesn't seem to have worked).

Edited by Lottario

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...