Jump to content
Sports Interactive Community

Can no longer join my friend's save - was working yesterday and over the last year as well

Recommended Posts


I need your help because this is driving me and my friend crazy now. Everything was working well in the past few months and we played no later than yesterday. 

And today, I can't join the game. I can see our game in the Join online menu, then I select the game and click Join Game at the bottom of the screen. After that, the small window appears saying Joining online game (and the rest of the screen is grey-black - see attached picture) but after a few seconds, instead of being into the game, I'm back at the previous screen with the list of all online games. Then, when I try a 2nd time to click Join Game it says ERROR Unable to connect to server.

I've tried other unlocked online games but same thing happens. 

My friend tried the same but it's not working either...

We tried to restart PCs & Steam multiple times, make sure we use the same download region, both run the same version 17.3.2, etc. And nothing happened since yesterday (no windows update or anything), so don't know why it's not working

Please help !!

Thank you in advance


Edited by alainalex09

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...