Jump to content
Sports Interactive Community

Recommended Posts

Summary: The game fails to launch after 3 to 5 seconds of the blue loading circle then nothing

Description of Issue: Game fails to launch

Steps to Reproduce:I bought the full game about 2 weeks ago.  I had previously played the free weekend/demo game a couple of months back on Steam.  So bought the game and downloaded it.  When I go to launch the game goes to load and we get the blue circle after 3 to 5 seconds this disappears but the game does not start.  Steam states the game is playing. I cant stop this, even closing down Steam the FM 20 is still running when I open Steam up, I do a 3 finger salute but FM 20 is not there.  Closed down restart, check and verified files, uninstalled, reinstalled same result, Checked my drivers, checked the Antivirus, checked the EXE. file checked direct x yet the game still does not start.  I have 16Gb Ram, I am using Ge Force 1060 6gb, I7 8700@3.2Ghz Win 10 64bit.  I have as far as I can see tried all the usual tips but nothing. Confused that the demo worked previously but the full game does not?  Any help is appreciated - Please remember I am computer dumb and need easy to follow instructions Thanks! 

Share this post


Link to post
Share on other sites

Could you attach your system dxdiag please so I can have a closer look at your machine specs, please:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...