Jump to content
Sports Interactive Community

Recommended Posts

I have just bought FM2020 touch for my iPad, however it wont download at all. The icon is on my home screen but it just keeps saying “Loading...” without actually doing anything. Ive tried deleting the data and trying the download again, ive also tried clearing more memory from my iPad incase that worked but still nothing.

I’ve noticed a few reviews on the app store saying the same thing. Any ideas on how to get it to work?

Share this post


Link to post
Share on other sites

Hi @Brad2705,

Sorry you are experiencing issues, could you please give us the model number of the device you are using; it can be found in Settings > General > About > Model Number.

Thanks,

Harrison

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...