Jump to content
Sports Interactive Community
Thib

DXGI_ERROR_DEVICE_RESET

Recommended Posts

Hello,

Since a couple of days or so, I keep experiencing crashes. (I hadn't played for a week or so)
I can progress in game, crashes happen randomly after seconds or sometimes hours.

It's 90% of the time I get a crash "DXGI_ERROR_DEVICE_RESET"

Or I also seen a once or twice "Application error A serious error was encountered and the game will now close"

First and last 2 dumps attached.

Latest Dxdiag attached too.

Files already verified. Tried without facepacks. And cleared the game cache.
I have tried rollback of the AMD drivers from 19.12.3 to 19.12.2, but it didn't change anything.

Changing of display mode or textimage ratio didn't help either. Removing the gazillion of USB device I use didn't solve anything either.

SFC scannow isn't detecting anything.

Weirdly enough the game always crashed outside of games.

A weird behaviour, but if the crash is DXGI_ERROR_DEVICE_RESET, the amd radeon software will stop working and be transparent.
I attached the msinfo error logs too as there is a pattern with the radeon software crashing.

amd.thumb.jpg.8b05b5b19b053a81ccd1a9179ce91a67.jpg

I haven't had any weird crash in other applications or games, and FM19 is still working as intended.

Any idea what the issue could be?

error1.jpgdxgi_error_device_reset.jpg.c436f9aec03256be5909b3b6f9177b6d.jpg

FM 2020 v20.2.3.1330207 (2019.12.23 20.32.20).dmp FM 2020 v20.2.3.1330207 (2019.12.23 20.45.12).dmp DxDiag.txt FM 2020 v20.2.3.1330207 (2019.12.20 23.39.00).dmp msinfo.txt

Edited by Thib
Adding some details & fixing a few typos

Share this post


Link to post
Share on other sites

Hi there,

Thanks for bringing this to our attention.

The information you've provided should hopefully reveal what is causing this issue.

For now I'd point you in the direction of an FAQ form on random crashes found here - 

 

Let me know if anything in here helps you at all.

Many thanks,

Tom

 

Share this post


Link to post
Share on other sites

Thanks for the FAQ link.

This didn't seems to change anything on my side.
 

Changing the amd radeon setting from the default "gaming" to "standard" has helped quite a bit, still a few crash, but nowhere near as regular. I have also since tried with all amd radeon settings to manual, and it now seems stable (hasn't crashed in 48h).
So it might be a link between some of the amd radeon features messing up somewhere.

Share this post


Link to post
Share on other sites

Thanks for letting us know, we will look into this further and will update you once we are able to. Thanks.

Share this post


Link to post
Share on other sites

@Thib, is your graphics card overclocked? IIRC I used to get this error on an overclocked card, but as soon as I set it back to a profile with factory settings the crashes stopped happening.

Share this post


Link to post
Share on other sites
On 31/12/2019 at 00:00, Shpamo said:

@Thib, is your graphics card overclocked? IIRC I used to get this error on an overclocked card, but as soon as I set it back to a profile with factory settings the crashes stopped happening.

Sorry for late reply. It might have been the radeon software doing an automatic overclock yeah. In manual it didn't happen once since (clocked 60h+ since)

Share this post


Link to post
Share on other sites

Thanks for that update, Thib. 

We'll continue trying to fix the original issue but glad you're currently able to play with no issues in the meantime.

Share this post


Link to post
Share on other sites

Yeah I'm getting similar issues with AMD Radeon TM RX 480 Graphics card, updated latest drivers but seems to crash very quickly. I'll try the solutions above in the Radeon dashboard...very frustrating.

Share this post


Link to post
Share on other sites

No problem, sorry to hear that. But let us know how you get on. 

Share this post


Link to post
Share on other sites

Yeah, please give Gunther's solution and let us know how it goes.

Share this post


Link to post
Share on other sites

Gunther's solution works too (with default radeon settings). I guess that by disabling the radeon software it disables the automatic overclock from it (as changing from automatic to manual overclock (left at 0 for me) when playing FM fixes the issue too)

Share this post


Link to post
Share on other sites

Thanks for letting us know that you've found a workaround. We will pass your information to the dev team and we will work to improve on the game optimization.

Thanks. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...