Jump to content
Sports Interactive Community
ItalianCelt

In-Game Editor Purchased but not showing

Recommended Posts

I imagine this may be a Steam Issue rather in the game itself but I'm completely stuck. I have purchased the In-Game Editor through Steam and installed it, I have the Steam Overlay enabled however when I go into the game and press the downloads button it repeatedly tells me that I need to enable the Steam Overlay (Which is already ticked in the Steam App). 

I have looked online and tried various solutions but so far nothing has worked.

Cheers in advance.

Share this post


Link to post
Share on other sites
1 hour ago, ItalianCelt said:

I imagine this may be a Steam Issue rather in the game itself but I'm completely stuck. I have purchased the In-Game Editor through Steam and installed it, I have the Steam Overlay enabled however when I go into the game and press the downloads button it repeatedly tells me that I need to enable the Steam Overlay (Which is already ticked in the Steam App). 

I have looked online and tried various solutions but so far nothing has worked.

Cheers in advance.

I am experiencing exactly the same error...please fix it asap.

Share this post


Link to post
Share on other sites
3 hours ago, ItalianCelt said:

I imagine this may be a Steam Issue rather in the game itself but I'm completely stuck. I have purchased the In-Game Editor through Steam and installed it, I have the Steam Overlay enabled however when I go into the game and press the downloads button it repeatedly tells me that I need to enable the Steam Overlay (Which is already ticked in the Steam App). 

I have looked online and tried various solutions but so far nothing has worked.

Cheers in advance.

Mine was working fine but just done the new update and its now disappeared and saying enable steam overlay which it is 

Share this post


Link to post
Share on other sites

Mine was a bit temperamental. It didn't work then it worked for a short while and now it's back to not working

Share this post


Link to post
Share on other sites

I am having the same issue. i cannot find it anywhere - in preferences, the box is checked but starting a new game or loading saved game... it is not there at all.. really annoying

Share this post


Link to post
Share on other sites

There is a little pencil icon at the end of the search bar and that is where the In Game Editor is. Stupid place to put it imo 

Share this post


Link to post
Share on other sites
12 hours ago, YankeeRam said:

There is a little pencil icon at the end of the search bar and that is where the In Game Editor is. Stupid place to put it imo 

Yeah, I can't even get that far. Before I load my game from the home screen if I press downloads it just tells me to 'Enable the Steam Overlay' which is already enabled. That's the issue I'm having :-( 

Share this post


Link to post
Share on other sites
15 hours ago, DannyLCFC1 said:

Mine was working fine but just done the new update and its now disappeared and saying enable steam overlay which it is 

 

14 hours ago, gonewrong said:

I am having the same issue. i cannot find it anywhere - in preferences, the box is checked but starting a new game or loading saved game... it is not there at all.. really annoying

 

1 hour ago, ItalianCelt said:

Yeah, I can't even get that far. Before I load my game from the home screen if I press downloads it just tells me to 'Enable the Steam Overlay' which is already enabled. That's the issue I'm having :-( 

Hi guys, this sounds like an issue with Steam I'm afraid. For help with this you will need to contact help@sega.co.uk

Share this post


Link to post
Share on other sites
1 hour ago, Freddie Sands said:

 

 

Hi guys, this sounds like an issue with Steam I'm afraid. For help with this you will need to contact help@sega.co.uk

Thought that might be the case. Thanks, I will give them an email.

Share this post


Link to post
Share on other sites
3 hours ago, ItalianCelt said:

Thought that might be the case. Thanks, I will give them an email.

Any response on how to solve this?

Thanks

Share this post


Link to post
Share on other sites
2 hours ago, markmullan said:

Any response on how to solve this?

Thanks

Not yet. Once I get a reply from them I will post on here.

Share this post


Link to post
Share on other sites

Long story short.... Bought the In Game Editor, Tried everything in my power to get it working, Been emailing Vincent from Sega for the past 2 days still with no joy what so ever. Deleted cache preferences etc etc Steam Libary states I have no DLC even though I have provided Sega my receipt for the purchase of the ingame editor. Getting really frustrated now as it should be a simple thing to install but cant for the life of me get it working! Only thing I havent tried is uninstalling the game and reinstalling but has anyone else had this issue and if so do a reinstall actually fix it?

Share this post


Link to post
Share on other sites

Got this response. It hasn't worked for me but thought I would share incase it helps anyone else.

 

 

Hello,

Please follow the instructions as stated for your Operating System:

To delete your cache, please do the following:

Mac OS X (all versions)

- Open Finder.
- Click the ‘Go’ menu in the menubar.
- Press and hold down the ‘Option’ (Alt) key.
- Click the ‘Library’ item in the menu.
- Go into the folder named ‘Application Support’ then ‘Sports Interactive’
- Click into the ‘Football Manager 2020’ folder
- Within here, delete the ‘Cache’ folder

After this is done, please verify the integrity of game cache as follows: 

- Load Steam
- From the Steam Games Library, right-click on Football Manager 2020 and select Properties from the menu.
- Select the Local files tab and click the Verify integrity of game cache... button.
- Steam will verify the game cache files (GCF's) - this process may take several minutes.
- Once the process is completed, the Check Window will automatically exit.

Now please start the game again and check if the Ingame Editor is now available in your game.

Please let us know how you get on.


Best Regards, 

Vincent
SEGA Customer Support

Share this post


Link to post
Share on other sites
1 hour ago, ItalianCelt said:

Got this response. It hasn't worked for me but thought I would share incase it helps anyone else.

 

 

Hello,

Please follow the instructions as stated for your Operating System:

To delete your cache, please do the following:

Mac OS X (all versions)

- Open Finder.
- Click the ‘Go’ menu in the menubar.
- Press and hold down the ‘Option’ (Alt) key.
- Click the ‘Library’ item in the menu.
- Go into the folder named ‘Application Support’ then ‘Sports Interactive’
- Click into the ‘Football Manager 2020’ folder
- Within here, delete the ‘Cache’ folder

After this is done, please verify the integrity of game cache as follows: 

- Load Steam
- From the Steam Games Library, right-click on Football Manager 2020 and select Properties from the menu.
- Select the Local files tab and click the Verify integrity of game cache... button.
- Steam will verify the game cache files (GCF's) - this process may take several minutes.
- Once the process is completed, the Check Window will automatically exit.

Now please start the game again and check if the Ingame Editor is now available in your game.

Please let us know how you get on.


Best Regards, 

Vincent
SEGA Customer Support

I'm afraid it didn't work here either.

Share this post


Link to post
Share on other sites

What you need to do is reinstall Steam then install it again. Worked for me then go on fm>downloads>ingameeditor.

Share this post


Link to post
Share on other sites
On 25/11/2019 at 18:19, markmullan said:

reinstall steam after following the above steps?

Reinstall steam launch fm then go to downloads.

Share this post


Link to post
Share on other sites

In-Game Editor disappeared in my game today.  It had been working with no issues.  Now it is grayed out.  

 

I go to FM-Preferences-Download and it says it is "activated."

 

I have cleared the Steam Cache, verified integrity of game file in Steam, uninstalled/reinstalled Steam and FM20....no change.

 

In-Game Editor is still grayed out.  

Share this post


Link to post
Share on other sites

Resolved my issue.   

 

I checked in game FM-Preferences-General...and Show In-Game Editor in Menu Bar was un-ticked!

 

I'm certain that I didn't un-tick it...but...I dunno...I have done plenty of things in my life and been completely oblivious to it.  

 

Maybe this will help some others out there.  Hope so.  

Share this post


Link to post
Share on other sites

Having the same problem with the in-game editor randomly disappearing. 

  • MacOS latest version.
  • Steam updated to latest version.
  • Get the message about the Steam Overlay not being enabled when clicking Downloads but it is enabled in the Steam settings.
  • Cleared my cache and verified game files. 
  • Show In-Game Editor option was ticked when creating a new game. 

Share this post


Link to post
Share on other sites

I just bought the ingame editor and nothing is showing. When I push downloads I also get the error code 1000. Very frustrating. 

Share this post


Link to post
Share on other sites
30 минут назад, lpcinder сказал:

I just bought the ingame editor and nothing is showing. When I push downloads I also get the error code 1000. Very frustrating. 

the same, error 1000

But it worked in first days for me

Edited by Novem9

Share this post


Link to post
Share on other sites

Same here. I currently have a ticket in with Sega customer support and I'll keep people updated here if they provide any useful help or advice.

Share this post


Link to post
Share on other sites
6 часов назад, Mike J сказал:

According to Sega this was a server issue. Working fine for me now.

still not fixed for me

Share this post


Link to post
Share on other sites

I think people are getting two different problems confused. 

  • Problem 1 - the editor is randomly disappearing and even after clearing cache, verifying game files etc is not appearing.
  • Problem 2 - the "error 1000" which was due to the server issues the other night.

Problem 1 was occurring for me before Problem 2 was a thing. I've also tested on my Windows setup and I have the same issue. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...