Jump to content
Sports Interactive Community
mrmogens

Nvidia Response Stuttering / low fps (possible fix)

Recommended Posts

Hellow fellow Managers

as seen on the forum their have been alot post regarding til Match Engine Stuttering and/or low fps or just generel lag issues.

As many of you ive tried alot of things also, such as:

* Reinstalling game

* Reinstalling GPU drivers

* trying different screen resolutions, ingame graphic settings, turned of gsync, launch options in steam and etc....

so after bit of communication with SI on email, where they suggested the problem could be a driver related problem. Ive contacted Nvidia in order to get their view of the problem. They gave me some options that i have not tried yet, because i am at work atm, so i will share it with you guys and future details as i begun a testing series for Nvidia in order to locate the cause to this problem, so i will update this post regularly as i get new information:

 

Latest TIP's and advises from Nvidia:

---------------------------------------FROM NVIDIA SUPPORT--------------------------------------------------

From the email description, I understand that you are experiencing issues in Football Manager 2019.
 
I apologize for any inconvenience this may have caused.
 
Please create a profile for Football Manager 2019 on NVIDIA Control Panel by following the steps below.
 
Open NVIDIA control panel (Right click on desktop and click NVIDIA control panel) > Go to Manage 3D settings under 3D Settings > Select Program settings > Select Football Manager 2019 under Step 1 (If you do not find it, click Add and add the game to the list)> Change the following settings under Option 2.
 
•    Power management mode - Prefer maximum performance
•    Threaded optimization - ON
•    Triple buffering - Off
•    Vertical Sync - Off
 
Click on "Apply" to save the changes.
__________________________________________________________________________________________________________________________________
 
(11/08/2018 10:46 PM) LATEST UPDATE
I checked the System Information file and can see the graphics card is detected correctly.
 
You may turn off Discord, run Football Manager 2019 in full screen mode and check if it runs properly.
 
If the issue still persists, it could be a issue with the game itself as all other games run fine. So I would request to check with the game developers to see if there are any known issues on their end and if they have any updates/patches to address it.
 
I look forward to your reply.
 
Best Regards,
NVIDIA Customer Care
__________________________________________________________________________________________________________________________________
 
Hello ######,
 
Thank you for the reply
 
We request you to check with the Game developer once in regards to this and share their feedback please
 
The hardware and software on your PC has no issues, the other games are also working aswell.
 
Looking forward for your update.
 
Best regards
#######
NVIDIA Customer Care
reply recieved from nvidia on (11/15/2018 15:46 PM) 
---------------------------------------^FROM NVIDIA SUPPORT^--------------------------------------------------
 
Feedback Status (based on reply):
Solved the problem =  50% fixing for some people (3D Match Engine)
Didn't solve problem = 50% didn't fix it (FPS drop elsewhere beside 3D M.E)
 
--------------------------------------->LATES UPDATE FROM ME>--------------------------------------------------
Latest reply recieved from nvidia on (11/08/2018 10:46 PM) 
Okay... I tried these suggestions on my rig, i have a gtx 1070ti card.  My Case is that i have
stuttering 3D match Engine AND i do have low fps when game is in idle mode, which mean 
when i moove around from lets say tactic screen and in to the inbox screen in carreer mode
i get low fps = 40fps
 
what i learned from the above settings is that it helped me have solid 3D match engine,
but still lags inform of random fps else where in the game.
ive used:
•    Power management mode - Prefer maximum performance
•    Threaded optimization - ON
•    Triple buffering - Off
•    Vertical Sync -if i turn VSYNC of i get alot of stuttering in 3D, so i turned this on fastest
 
i have contacted Nvidia and told them about my experience and are waiting their reply 
 
Latest reply recieved from nvidia on (11/08/2018 10:46 PM) 
__________________________________________________________________________________________________________________________________
Latest reply recieved from SIGA on (11/12/2018 12:00 PM)  (12/11/2018 in Danish Calendar )

<

So as ive got the final testing done for Nvidia, they have concluded that it is not my hardware that are causing theese problems, and they are suggesting me to contact the game developers, in which i have.

soo now i just await reply from SIGA in my mail, not this thread! and i will of course share my future knowledge on this point, but just to conclude, the problem for me is the unstable fps general ingame besides 3D Match Engine which works perfectly, but the rest of the game is still a critical asset that i hope will be solved in a future hotfix 

>

Latest reply recieved from SIGA on (11/12/2018 12:00 PM)  (12/11/2018 in Danish Calendar )
 
---------------------------------------^LATES UPDATE FROM ME^--------------------------------------------------
 
Be sure to reply if above solved any issues in your part :)
 
 
Best regards
 
Edited by mrmogens

Share this post


Link to post
Share on other sites

Great work I'll try when I'm home and report back. Interesting it recommends vsync off as it seems to improve on fast setting.

At least we've got a response from Nvidia which is a start👍

Share this post


Link to post
Share on other sites
1 minute ago, dansh1989 said:

Great work I'll try when I'm home and report back. Interesting it recommends vsync off as it seems to improve on fast setting.

At least we've got a response from Nvidia which is a start👍

Yea it is a start, already got one reply in my inbox from a user saying it gave him max fps, so a pretty positive response  :applause:

Share this post


Link to post
Share on other sites

Hey, thanks for providing this information for everyone to try!

If these settings don't work, I'd suggest also trying the same settings but with threading optimisation turned off.

Share this post


Link to post
Share on other sites

Whats the equivalent for Radeon?

I can't seem to find any power options or threaded optimisation?

cheers

 

EDIT:

Tried turning VSync and Triple buffering off - no joy.

Edited by RorysRocketThrow

Share this post


Link to post
Share on other sites
11 minutes ago, RorysRocketThrow said:

Whats the equivalent for Radeon?

I can't seem to find any power options or threaded optimisation?

cheers

Well most people who had problems are NVIDIA users. To turn off threaded optimisation you can add this manually in the launch propeties of the game in Steam.

Football Manager 2019 > properties > launch options > add this line: -disable_threading_optimisations

I have no clue how you alter the other settings on a AMD card. Google it.

 

Edited by Sanel

Share this post


Link to post
Share on other sites
2 minutes ago, Sanel said:

Well most people who had problems are NVIDIA users. To turn off threaded optimilisation you can add this manually in the launch propeties of the game in Steam.

Football Manager 2019 > properties > launch options > add this line: -disable_threading_optimisations

I have no clue how you alter the other settings on a AMD card. Google it.

 

I have googled it.  No joy.  Just wondered if one of the more helpful members of this community, with more knowledge than myself, knew anything about it.

Why would I want to turn off threaded optimisation when the original post suggests it should be on?

Edited by RorysRocketThrow

Share this post


Link to post
Share on other sites
9 minutes ago, RorysRocketThrow said:

I have googled it.  No joy.  Just wondered if one of the more helpful members of this community, with more knowledge than myself, knew anything about it.

Why would I want to turn off threaded optimisation when the original post suggests it should be on?

I misread it, changed the settings this afternoon. Someone at SI posted here that disabling it could make a difference as well. You have to keep in mind that the settings can be different on a AMD card, but you can try. https://support.amd.com/en-us/kb-articles/Pages/DH-012.aspx, here you go. 

 

Edited by Sanel

Share this post


Link to post
Share on other sites
3 minutes ago, Sanel said:

I misread it, changed the settings this afternoon. Someone at SI posted here that disabling it could make a difference as well. You have to keep in mind that the settings can be different on a AMD card, but you can try. https://support.amd.com/en-us/kb-articles/Pages/DH-012.aspx, here you go. 

 

Thank you sir, i've been through that article before (i've lost count how many times), but will go through it again incase I have missed something.

Share this post


Link to post
Share on other sites
--------------------------------------->LATES UPDATE FROM ME>--------------------------------------------------
Okay... I tried these suggestions on my rig, i have a gtx 1070ti card.  My Case is that i have
stuttering 3D match Engine AND i do have low fps when game is in idle mode, which mean 
when i moove around from lets say tactic screen and in to the inbox screen in carreer mode
i get low fps = 40fps
 
what i learned from the above settings is that it helped me have solid 3D match engine,
but still lags inform of random fps else where in the game.
ive used:
•    Power management mode - Prefer maximum performance
•    Threaded optimization - ON
•    Triple buffering - Off
•    Vertical Sync -if i turn VSYNC of i get alot of stuttering in 3D, so i turned this on fastest
 
i have contacted Nvidia and told them about my experience and are waiting their reply 
---------------------------------------^LATES UPDATE FROM ME^--------------------------------------------------

Share this post


Link to post
Share on other sites
---------------------------------------FROM NVIDIA SUPPORT--------------------------------------------------
(11/08/2018 10:46 PM) LATEST UPDATE
I checked the System Information file and can see the graphics card is detected correctly.
 
You may turn off Discord, run Football Manager 2019 in full screen mode and check if it runs properly.
 
If the issue still persists, it could be a issue with the game itself as all other games run fine. So I would request to check with the game developers to see if there are any known issues on their end and if they have any updates/patches to address it.
 
I look forward to your reply.
 
Best Regards,
NVIDIA Customer Care
 
---------------------------------------^FROM NVIDIA SUPPORT^--------------------------------------------------

Share this post


Link to post
Share on other sites

Problem is I don't think SI know what's causing this or how to fix it so were pretty much stuck with another unplayable game. For this to happen in the last 2 versions of the game is no coincidence, there is something wrong somewhere.

The only camera angle that never stutters is the data analyst for me but the players are so small you can't really see what's going on especially if the kit colours are similar.

Looks like it's back to FM17 👎

Share this post


Link to post
Share on other sites
29 minutes ago, dansh1989 said:

Problem is I don't think SI know what's causing this or how to fix it so were pretty much stuck with another unplayable game. For this to happen in the last 2 versions of the game is no coincidence, there is something wrong somewhere.

The only camera angle that never stutters is the data analyst for me but the players are so small you can't really see what's going on especially if the kit colours are similar.

Looks like it's back to FM17 👎

yea thats the reason why i also have been playing FM17 until now, but yea maybe it is time to go back to fully working game.

Share this post


Link to post
Share on other sites

is it any way to take my money back ??? I could not able to play last year too. and same disaster this year. any tips work for me. No way ! I have High end Nvidia and play Call of Duty with no problem !!! Lol ! Si I want my money BACK !

Share this post


Link to post
Share on other sites
2 hours ago, dmndmn said:

is it any way to take my money back ??? I could not able to play last year too. and same disaster this year. any tips work for me. No way ! I have High end Nvidia and play Call of Duty with no problem !!! Lol ! Si I want my money BACK !

Do a request directly through steam, your guaranteed the money back if you explain the situation. If brought from somewhere else and activated through steam, you wont get your money back illegally they refuse.

Share this post


Link to post
Share on other sites
2 hours ago, dmndmn said:

is it any way to take my money back ??? I could not able to play last year too. and same disaster this year. any tips work for me. No way ! I have High end Nvidia and play Call of Duty with no problem !!! Lol ! Si I want my money BACK !

You'd need to take this up with whichever retailer you bought the game from.

Share this post


Link to post
Share on other sites

And SI isn’t working on this solution? THANKS SI! :mad:

Edited by apsychoshow

Share this post


Link to post
Share on other sites
8 saat önce, Jack Joyce said:

You'd need to take this up with whichever retailer you bought the game from.

What I am gonna say to retailer? Its a shopping centre in istanbul, its because of you that have no idea how to help me like last year !

Share this post


Link to post
Share on other sites

I had this problem (stuttering graphics using a high-end NVIDIA card) and was able to solve it by changing v-sync to "fast".  I haven't bought FM19 yet but am I to understand it still hasn't been fixed?  In a whole year?  It's absolutely bonkers that FM has more graphical issues than games like GTA5 or Witcher 3.

Share this post


Link to post
Share on other sites

Since the latest nvidia driver update  for GE Force GTX 850M notebook (8th November) I have experienced above problems with the match engine, will try suggestions and advise, would a roll back on the drivers be a good idea? 

Share this post


Link to post
Share on other sites
21 hours ago, Glenn Douglas said:

Since the latest nvidia driver update  for GE Force GTX 850M notebook (8th November) I have experienced above problems with the match engine, will try suggestions and advise, would a roll back on the drivers be a good idea? 

Have the same Nvidia also laptop. Updated the 8. November driver and it's been stuttering since. Never had this before on FM. 

Anyone with an Nvidia playing FM. Don't update the driver. 

Share this post


Link to post
Share on other sites

The changes worked for the 3D match engine but has slowed the othe aspects of the games like go to different screens and evening saving the game (horribly slow now). I will be reverting to the old settings as the new shuttering is worse than the one in the match engine previously 

Share this post


Link to post
Share on other sites

I did the changes described above by nvidia and it works again. 

Share this post


Link to post
Share on other sites

I've been playing with settings in Nvidia control panel and Nvidia inspector and the stutter is back to almost minimal literally the odd single frame. I'm playing on a laptop and during a match im getting locked at 60fps. Is the match engine capped at 60fps? It's really smooth now just the odd jitter but was just curious about the fps?

A few things I changed was on control panel set everything possible to max performance related rather than quality.

Also in Nvidia inspector I have gysnc off. Vsync on fast and prefer max frame refresh rate or highest available.

Max pre rendered frames to 4.

Single display performance mode ( this really made a difference! But as I say using a laptop)

Threaded optimisation to OFF.

Just thought I'd share a few settings. Give it a try, my stuttering may return like before but for now it's almost perfect.

Shut down and reboot FM19 too after applying changes 👍

Edited by dansh1989

Share this post


Link to post
Share on other sites

This worked for me. Checked the nvidia 3d settings solution mentioned and In the options, the default chosen was for the integrated graphics card rather than the nvidia graphics card. Swapping the graphics card from integrated to high performance nvidia processor seems to fix the stutter. Didnt have to modify other settings

Share this post


Link to post
Share on other sites
On 11/11/2018 at 08:50, Macdee8 said:

The changes worked for the 3D match engine but has slowed the othe aspects of the games like go to different screens and evening saving the game (horribly slow now). I will be reverting to the old settings as the new shuttering is worse than the one in the match engine previously 

These changes wouldn't make any difference to saving/loading speeds. That's determined by your CPU which is completely different.

Since the suggested fix is working for so many people I think we'll sticky this topic, thanks @mrmogens!

Share this post


Link to post
Share on other sites
27 minutes ago, Jack Joyce said:

These changes wouldn't make any difference to saving/loading speeds. That's determined by your CPU which is completely different.

Since the suggested fix is working for so many people I think we'll sticky this topic, thanks @mrmogens!

I am glad that it helped some people, and i makes sense that you make it sticky so that people dont make the same post about the same problem :) and i will keep updating this post if i get more helpfull feedback from nvidia that may help some more :)

Share this post


Link to post
Share on other sites

It worked for me THX!

I have a gigabyte 1070

If you have a gsync monitor, don't use the gsync feature. I changed the Monitor technology to fixed refresh and the flikkering / stuttering is no longer there. 

image.thumb.png.8700581c6326dfa4d1587ec2158a4a9a.png

image.png

Hope this helps. 

 

And thanks for @mrmogens for sharing this. 

 

Edited by iisaak

Share this post


Link to post
Share on other sites
12 hours ago, iisaak said:

It worked for me THX!

I have a gigabyte 1070

If you have a gsync monitor, don't use the gsync feature. I changed the Monitor technology to fixed refresh and the flikkering / stuttering is no longer there. 

image.thumb.png.8700581c6326dfa4d1587ec2158a4a9a.png

image.png

Hope this helps. 

 

And thanks for @mrmogens for sharing this. 

 

@iisaak

So did it fix your 3D match engine stuttering or the generel stable FPS through out the game like imentioned in the Orginal Post, its just to clearify because people are experiencing two problems :) Glad it helped you

Share this post


Link to post
Share on other sites

I'm running a laptop With NVIDIA gtx 150. Lagged like hell, but then i updated the drivers to the newest as of an hour ago. Changed settings in the NVIDIA Control panel to actually use NVIDIA Graphics and not the Integrated card (the Integrated card was the default setting) and now it Works like an absolute charm With high gfx-settings. And i won the first game after the update 5-2. Pretty nifty. 

Share this post


Link to post
Share on other sites
5 hours ago, fiskehodet said:

I'm running a laptop With NVIDIA gtx 150. Lagged like hell, but then i updated the drivers to the newest as of an hour ago. Changed settings in the NVIDIA Control panel to actually use NVIDIA Graphics and not the Integrated card (the Integrated card was the default setting) and now it Works like an absolute charm With high gfx-settings. And i won the first game after the update 5-2. Pretty nifty. 

well this dosn't sound like an actual problem with nvidia or the game its just something you often see with laptops, they dont always use the best graphics card in the laptop in order to save battery life, so this sounds normal. But if you provide what version og graphics driver you installed, this could help others to determine if they have similiar settings.

Share this post


Link to post
Share on other sites
2 hours ago, mrmogens said:

well this dosn't sound like an actual problem with nvidia or the game its just something you often see with laptops, they dont always use the best graphics card in the laptop in order to save battery life, so this sounds normal. But if you provide what version og graphics driver you installed, this could help others to determine if they have similiar settings.

Yeah this can be a common issue with laptops where you don't realise that your machine is using the wrong graphics card. Sometimes it changes down to your integrated GPU due to your power management settings too (set those to max performance).

Share this post


Link to post
Share on other sites

This thread was very helpfull to me, fixed the problems I had. But today I have a new update of NVIDIA driver. Anyone tried it already? Don't know if should install or not.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...