Jump to content
Sports Interactive Community
wixta79

stuttering match engine

Recommended Posts

The lag on the match engine is driving me mad, scoured the forums and tried all the advice.

my rig is 

Geforce GTX 1050

intel(r) core(TM) i7-7700hq CPU @ 2.80GHz

7.89 GB ram

1920 x 1080 60Hz

please help

Share this post


Link to post
Share on other sites

FMT has no such problems, runs like a dream, even gives me 5 star graphic rating, where main game only gives me 3?

Share this post


Link to post
Share on other sites

Hi @wixta79 and @laney25

In the 19.1 update we added a command line option to disable thread optimisation, which has apparently helped with similar lag issues on other games. Go to football manager 2019 on steam, right click and go to properties then 'set launch options'. Put this in "-disable_threading_optimisations".

Please let me know if this improves the performance for you!

Share this post


Link to post
Share on other sites
9 minutes ago, wixta79 said:

tried this nothing changed, unless I put " in when I shouldn't?

Try without the quotation marks and let me know

Share this post


Link to post
Share on other sites

I've noticed the same issue, on BETA, I played on medium settings, the full game is using exactly the same settings but it's stuttering! 

Share this post


Link to post
Share on other sites

 

21 hours ago, Ben Allingham said:

Hi @wixta79 and @laney25

In the 19.1 update we added a command line option to disable thread optimisation, which has apparently helped with similar lag issues on other games. Go to football manager 2019 on steam, right click and go to properties then 'set launch options'. Put this in "-disable_threading_optimisations".

Please let me know if this improves the performance for you!

So should everyone else try this to see if it works?

Share this post


Link to post
Share on other sites

I tried it, but nothing happened, so how do you know if anything worked?

Share this post


Link to post
Share on other sites
4 hours ago, stevemc said:

I tried it, but nothing happened, so how do you know if anything worked?

Where did I say it worked?

Share this post


Link to post
Share on other sites
1 minute ago, Armistice said:

Where did I say it worked?

I didn't mean you per se, I mean't I also tried it but nothing happened (you don't get an notification or anything) so how can you actually tell anything happened?

Share this post


Link to post
Share on other sites
1 minute ago, stevemc said:

I didn't mean you per se, I mean't I also tried it but nothing happened (you don't get an notification or anything) so how can you actually tell anything happened?

Oh I see, I believe ME must not stutter anymore if this works.

Share this post


Link to post
Share on other sites
1 minute ago, Armistice said:

Oh I see, I believe ME must not stutter anymore if this works.

Well mine still stutters so it didn't work for me :D

Share this post


Link to post
Share on other sites

The beta was fine for me, can't they just revert back whatever they changed from beta to release?

Share this post


Link to post
Share on other sites

Can all suffering from this try two things please?

1. Move the mouse whilst playing and see if that eliminates lag?

2. Download a screen recording software such as Filmora and have it running idle in the background?

I've been having this issue since the back end of FM18 and so far have not had any consistent joy other than the two steps above that eliminate my lag consistently.

If you can do those steps please report back with the results.

Thank you.

Share this post


Link to post
Share on other sites

ok just downloaded a trial version of filmora, it is open in the background and no change.

Also moving the mouse has no impact.

for the record I have issues since the back end of FM18 also.

At the time I linked it to the windows 10 update, I kept reverting to the previous windows and everything was fine again.

But in the end I got annoyed with my laptop constantly trying to update that I gave in hoping this new FM19 would be smooth.

Share this post


Link to post
Share on other sites
1 hour ago, wixta79 said:

ok just downloaded a trial version of filmora, it is open in the background and no change.

Also moving the mouse has no impact.

for the record I have issues since the back end of FM18 also.

At the time I linked it to the windows 10 update, I kept reverting to the previous windows and everything was fine again.

But in the end I got annoyed with my laptop constantly trying to update that I gave in hoping this new FM19 would be smooth.

Thanks

The idea was to try and give the Devs some info in that we are either looking at one problem or more than one problem.

Which update was causing the issue for you?

Share this post


Link to post
Share on other sites

Had the same problem in FM18 now in FM19. For me only works if I low the screen resoltution. However this should be fixed. I should be allowed to get the max of my pc. 

Share this post


Link to post
Share on other sites
32 minutes ago, RorysRocketThrow said:

Thanks

The idea was to try and give the Devs some info in that we are either looking at one problem or more than one problem.

Which update was causing the issue for you?

I cant remember exactly but it was a pretty big one and it was earlier his year I think

Share this post


Link to post
Share on other sites
32 minutes ago, Lickenfoot said:

Had the same problem in FM18 now in FM19. For me only works if I low the screen resoltution. However this should be fixed. I should be allowed to get the max of my pc. 

just tried lowering the screen resolution and its running much smoother

BUT now it looks poor 

EDIT still some lag but not as much as before

Edited by wixta79

Share this post


Link to post
Share on other sites

Are you all experiencing this on PC's? I only ask because I'm on a MacBook.

Share this post


Link to post
Share on other sites

i got the same issue.
had 75 fps while beta in 2d match engine, everything was fine. now i got 60-65 fps for no reason - nothing changed on my pc -, i even updated the gpu driver but nothing changed, match engine still lagging.
but when i move the mouse while highlights around the fps goes up to 75 fps immidiatly, when i stop lagging starts again.

i tried reload skin, clear cache, every possibilty.
this cant be normal.

Share this post


Link to post
Share on other sites

It's weird, something defo changed between Beta and full release, and it needs addressing.

Share this post


Link to post
Share on other sites

There seems to be something wrong with the game's built in VSync implementation. 

If you have an NVIDIA card, set up a profile for FM19 in the NVIDIA control panel and force Vsync to 'Fast'. This solved the issue for me.

Edited by bar333

Share this post


Link to post
Share on other sites
1 hour ago, spctr said:

i got the same issue.
had 75 fps while beta in 2d match engine, everything was fine. now i got 60-65 fps for no reason - nothing changed on my pc -, i even updated the gpu driver but nothing changed, match engine still lagging.
but when i move the mouse while highlights around the fps goes up to 75 fps immidiatly, when i stop lagging starts again.

i tried reload skin, clear cache, every possibilty.
this cant be normal.

@Jack Joyce

I think is a bit more evidence for you and the dev team.

Share this post


Link to post
Share on other sites
1 hour ago, bar333 said:

There seems to be something wrong with the game's built in VSync implementation. 

If you have an NVIDIA card, set up a profile for FM19 in the NVIDIA control panel and force Vsync to 'Fast'. This solved the issue for me.

I agree. I’ve had the same lag problem on FM 18, I have done this since the FM 19 beta and it has been running smoothly. With the odd occasional lag/stutter. Even after 19.1 update, I’m having no problems. Fingers crossed it stays this way. 

I definelty think it has something to do with the games built in V-Sync. 

Share this post


Link to post
Share on other sites

Turning off all gsync options and putting vsync to fast solved any stuttering for me during the beta and into full release. Definitely worth trying 👍

Share this post


Link to post
Share on other sites
1 minute ago, dansh1989 said:

Turning off all gsync options and putting vsync to fast solved any stuttering for me during the beta and into full release. Definitely worth trying 👍

yea i just turned AMD FreeSync On for FM19 and looks like it solved the problem.

Share this post


Link to post
Share on other sites
7 hours ago, dansh1989 said:

Turning off all gsync options and putting vsync to fast solved any stuttering for me during the beta and into full release. Definitely worth trying 👍

So how do we do that? And what’s V Sync?

Share this post


Link to post
Share on other sites
1 hour ago, Armistice said:

So how do we do that? And what’s V Sync?

VSync is vertical sync - it's a setting that synchronizes the frames rendered by your GPU with your monitor's native refresh rate. This prevents an effect called screen tearing.

You can force it through your graphics card's driver software. What graphics card do you have? 

Edited by bar333

Share this post


Link to post
Share on other sites

Just to note in my Nvidia control settings I have no gsync or vsync options. I downloaded a program called "Nvidia inspector" which gives you a lot more options than the control panel.

Share this post


Link to post
Share on other sites
1 hour ago, bar333 said:

VSync is vertical sync - it's a setting that synchronizes the frames rendered by your GPU with your monitor's native refresh rate. This prevents an effect called screen tearing.

You can force it through your graphics card's driver software. What graphics card do you have? 

How do you do this on a Mac then?

Share this post


Link to post
Share on other sites
13 hours ago, dansh1989 said:

Turning off all gsync options and putting vsync to fast solved any stuttering for me during the beta and into full release. Definitely worth trying 👍

Seems to have fixed it for me as well

Share this post


Link to post
Share on other sites
5 hours ago, bar333 said:

VSync is vertical sync - it's a setting that synchronizes the frames rendered by your GPU with your monitor's native refresh rate. This prevents an effect called screen tearing.

You can force it through your graphics card's driver software. What graphics card do you have? 

GeForce 740M.

Edited by Armistice

Share this post


Link to post
Share on other sites

Well assuming it's drivers work the same way as the ones for desktop GPU's:

Right click on your desktop -> NVIDIA Control Panel -> On the left panel, click 'Manage 3D settings' -> Program Settings -> From the dropdown menu, find the FM19 exe. If it's not there click 'Add' and navigate to the game's folder and add it -> Scroll down to Vertical Sync and set it to 'Fast'. Apply.

To the person who asked, I'm not sure if it's the same on Mac, sorry. Try it out.

Edited by bar333

Share this post


Link to post
Share on other sites

i hav also experienced this kinda trouble since the update/fullRealease 

getting 40 fps in start menu, and random fps drop through Match Engine and in carrer mode. 

i do have a GTX 1070ti 8Gb, so it not a lack of hardware. ive tried disabling G-sync and it didnt help. 

But i will try the V-sync setup that people are suggestion and return to let you guys know if it helped me.

i also noticed that if i moved my mouse around ingame in tactics menu and so.. the fps would stay on 144 (my screen max hz) if this guides to any soulotions.

Share this post


Link to post
Share on other sites
2 hours ago, mrmogens said:

i hav also experienced this kinda trouble since the update/fullRealease 

getting 40 fps in start menu, and random fps drop through Match Engine and in carrer mode. 

i do have a GTX 1070ti 8Gb, so it not a lack of hardware. ive tried disabling G-sync and it didnt help. 

But i will try the V-sync setup that people are suggestion and return to let you guys know if it helped me.

i also noticed that if i moved my mouse around ingame in tactics menu and so.. the fps would stay on 144 (my screen max hz) if this guides to any soulotions.

Getting a much more fluid Match Engine now!

 

But still at 40 fps in game mode inbetween games, but i noticed that if i moove my mouse around constantly i achieve 144 fps = my screen hz?

so for some reason the fps cap is at 40 when the game is idle :S

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...