Jump to content
Sports Interactive Community

Recommended Posts

I bought and downloaded FM 18 without any problems, but when I try to play the game it puts me in its loading screen, plays the music for about 10 seconds and each time after that it crashes without any feedback as to why. 

I looked through other topics for the same problem, and I noticed it helps to have my DxDiag, so I downloaded it, and will have it attached here if it helps

 

DxDiag.txt

Share this post


Link to post
Share on other sites

I'm very sorry to say your system does not meet the minimum specifications to run the game due to the graphics card. You would need to get a better system or request a refund for the game.

The minimum specs have increased since FM17. 

Apologies about that. 

Share this post


Link to post
Share on other sites

 

I see. It is odd though. Last year I tried the FM 17 Demo to get a feel of the game on this same system, and it ran (and still runs) perfectly fine. This is probably because it is simply a demo and obviously doesn't contain nearly as much information, but I can't say I know much about the subject. I trust that your recommendation is correct. I've been looking for a new laptop this past month but I was thinking whether or not getting the game on this system would be worth it. I guess this means I'll either get that new laptop, or, as you've said yourself, refund the game. Thank you for the reply, Brock. 

Share this post


Link to post
Share on other sites

As said, it's because the minimum specs have increased since FM17. Sorry that your system just fell in the gap between being able to run FM17 and not running FM18. :( 

Share this post


Link to post
Share on other sites

Hello I am having the exact same issue, expect the game was running perfectly up until the recent update. So has the newest update boosted the minimum requirements now ?

Share this post


Link to post
Share on other sites

@jokermania

The update didn't change the min spec for the game. Your issue was likely not related to the above problem but thanks for letting us know it's working anyway. 

If you do run into any issues again, please start your own thread. 

Thanks again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...