Jump to content
Sports Interactive Community
MagnusTen

In Game Editor Not showing up

Recommended Posts

3 hours ago, rhenders said:

I'm having this exact same problem as well.     Care to share your idea?

Also on MacBook!, can't purchase anything from that screen

Share this post


Link to post
Share on other sites

Anyone know how to purchase the editor in-game through a MacBook, i keep getting sent to this screen where i cannot click anything expert cancel transaction!

Share this post


Link to post
Share on other sites

@Lucas

 

I am having the same issue whereby the overlay sits in the bottom left-hand corner and I am unable to make any action, can you PM me details as to how to fix for mac?

Screen Shot 2017-11-10 at 07.07.35.png

Edited by MMC_CMM

Share this post


Link to post
Share on other sites
7 minutes ago, MMC_CMM said:

@Lucas

 

I am having the same issue, can you PM me details as to how to fix for mac?

Screen Shot 2017-11-10 at 07.07.35.png

Same here. MacBook Pro and not able to click something in the download window.

Share this post


Link to post
Share on other sites

I use a Mac Pro and I couldn't get it from the downloads so I went into steam to buy it. Managed to do that last night but still can't access it this morning.

Share this post


Link to post
Share on other sites

Same issue. Can't buy on Mac because of an awkward unresponsive window. Bought it on the website and doesn't work...

Just wondering... Isn't beta supposed to test these kind of issues?

When will the fix come?

Share this post


Link to post
Share on other sites

So bought from Steam didn't work as above. Bought ingame seemed to work just fine. I have the option in preferences but can't see the little pencil thing to edit anything. Default Skin, cleared the cache also and restarted Steam and FM18.

 

Any ideas please?

 

 

Screen Shot 2017-11-10 at 09.14.28.png

Share this post


Link to post
Share on other sites
2 hours ago, tbat44 said:

Same here. MacBook Pro and not able to click something in the download window.

Solved my problem. Switched back to english language (had a german custom file) and bought it at the main menu. It´s working now.

Share this post


Link to post
Share on other sites

Ok guys just tried something and it did work for me. First uncheck Use Retina Display option from the preferences. Now close the game and exit steam, reopen everything and hopefully it will also work for you :)

 

Share this post


Link to post
Share on other sites
9 minutes ago, Lucas Weatherby said:

Is it showing up for you in game?

Yes, but I'm worried there might be issues if I uninstall/reinstall Steam & FM 18 in the future.

Share this post


Link to post
Share on other sites

Please contact help@sega.co.uk for help with that keith.

Share this post


Link to post
Share on other sites

Works now! I had this problem, and I just loaded the game and it says unlocked. Loaded a save, and I see the editor options.

Share this post


Link to post
Share on other sites
2 minutes ago, Kingstontom88 said:

Still not appearing for me - tried reloading  skin/clearing cache - anything else I can try?

Did you purchase via Steam or make an in game purchase?

Share this post


Link to post
Share on other sites
4 minutes ago, Heywood JaBlowme said:

Did you purchase via Steam or make an in game purchase?

In-game, but it redirected me to Steam to purchase...?

Share this post


Link to post
Share on other sites
2 minutes ago, Kingstontom88 said:

In-game, but it redirected me to Steam to purchase...?

The transaction went through & the Show In Game Editor option is checked in Preferences? 

Share this post


Link to post
Share on other sites

Also on Mac and not able to purchase the editor because the Steam overlay is unresponsive to my clicks. Not even able to tab my way to add funds, but can when prompted to cancel.

My way around it was to uncheck the retina option in preferences, restart FM18, purchase the editor, recheck retina option in preferences, and then restart.

Not ideal I know but we’re kind of used to it by know. More clicks.

Share this post


Link to post
Share on other sites
3 minutes ago, Heywood JaBlowme said:

The transaction went through & the Show In Game Editor option is checked in Preferences? 

*sigh* I think a long working week has caught up with me - just realised I'd added cash to my Steam wallet but not actually purchased the editor, which I figured it had done...

Just purchased properly this time and it's there. Donut :lol:

 

Share this post


Link to post
Share on other sites
1 minute ago, Kingstontom88 said:

*sigh* I think a long working week has caught up with me - just realised I'd added cash to my Steam wallet but not actually purchased the editor, which I figured it had done...

Just purchased properly this time and it's there. Donut :lol:

 

:thup:

Share this post


Link to post
Share on other sites

I bought this on steam, not through game. Says its in library. tried logging out, restarting steam. clearing cache/preferences. clearing steam download cache. nothing.

tried getting refund so I could just buy in game but they told me I've exceeded max 2 hour playing game (but that's for the game, not the in game editor). I planned to just use refunded balance in wallet to buy it in game.

 

at a loss.

 

Share this post


Link to post
Share on other sites

This is the earliest I could check back, and it works for me now. Thanks for the fix, SI :)

 

To those still having an issue, I hope you find a solution!

Share this post


Link to post
Share on other sites
14 hours ago, MagnusTen said:

This is the earliest I could check back, and it works for me now. Thanks for the fix, SI :)

 

To those still having an issue, I hope you find a solution!

Is it now working via Steam purchase or still only In Game? If In Game only, this should really be high priority for SI for those who paid for the editor through Steam. 

Share this post


Link to post
Share on other sites
On 11/10/2017 at 10:59, Lucas Weatherby said:

You have a PM. :)

I have the exact same problem can you help me out also? The unresponsive mini screen appears whenever I try to purchase and I can't buy it. Thanks a lot!

Share this post


Link to post
Share on other sites

Please help, it's not showing up for me either. Purchased through the Downloads section in game.

image.thumb.png.b8ea1ff5d4b434e0e099d7dc4beb82f7.png

 

Cleared cache, deleted preferences file, restarted PC/Steam, load save game, ticked Show In-Game editor in the menu bar.....still nothing, don't see the pencil icon on any screen.

Do you need to start a new save for this to work?

Edit: Oh and first post!

Edited by mercedescolomar

Share this post


Link to post
Share on other sites

Also bought this in-game.

Not showing though.

Also not showing as bought on steam, although it is listed in my steam payment history?!

Edited by BamBamBam

Share this post


Link to post
Share on other sites
On 27/12/2017 at 11:57, BamBamBam said:

Also bought this in-game.

Not showing though.

Also not showing as bought on steam, although it is listed in my steam payment history?!

 I started a thread on this subject too; it was appearing at one point however since updating it's gone! :idiot:

Share this post


Link to post
Share on other sites

Did you already verifying the game cache in steam? (right click, properties, local data, verifying integrty of the game cache)

Share this post


Link to post
Share on other sites
9 minutes ago, KUBI said:

Did you already verifying the game cache in steam? (right click, properties, local data, verifying integrty of the game cache)

I've done this - all files were successfully validated; unfortunately the issue remained.

Share this post


Link to post
Share on other sites

Received this from SEGA:

Dear Customer,

Thank you for contacting SEGA Support.

We are sorry to read that you are encountering this issue with the ingame editor in FM18.

Please delete the cache files of your Football Manager 2018.

To delete your cache, please do the following:

First make sure the game is closed then please do the following:

For Windows Vista and Windows 7:
- Click ‘Start’
- Select ‘Computer’
- From the header, select ‘Organize’ dropdown
- Select ‘Folder and Search Options’
- Within here, select the ‘View’ tab and make sure ‘Show Hidden Files and Folders’ is selected
- Navigate to C:\Users\Your Username\AppData\Local\Sports Interactive\Football Manager 2018
- Delete the ‘Cache’ folder

For Windows 8 and Windows 10:
- Click ‘File Explorer’ from within the taskbar (or click ‘Desktop/Start’ then type in ‘File Explorer’)
- On the header click ‘View’ and make sure above ‘Show/hide’ that ‘Hidden Items’ is ticked
- Navigate to C:\Users\Your Username\AppData\Local\Sports Interactive\Football Manager 2018
- Delete the ‘Cache’ folder

After this is done, please verify the integrity of game cache as follows: 
- Load Steam
- From the Steam Games Library, right-click on Football Manager 2018 and select Properties from the menu.
- Select the Local files tab and click the Verify integrity of game cache... button.
- Steam will verify the game cache files (GCF's) - this process may take several minutes.
- Once the process is completed, the Check Window will automatically exit.

Now please start the game again and check if the Ingame Editor is now available in your game.

Please let us know how you get on.

Best Regards,

Vincent
SEGA Customer Support

 

It didn't work!!!!!

Share this post


Link to post
Share on other sites

This is now happening to me. I can't seem to use the in-game editor despite having used it previously. Anybody else having issues with it?

Thanks.

Share this post


Link to post
Share on other sites

Same issue here but strangely only on my laptop. Bought ige (ingame) on my pc and it's working. Playing on my laptop now and it still says "unlocked" but nothing showing up... Same save, with and without skin, prefs and cache cleared, files verified... Nothing helps...

Share this post


Link to post
Share on other sites

I have the same issue on iMac. Installed and worked fine, uninstalled and reinstalled everything (cleared cache, verified files etc) but now the editor functionality has gone from my game! :(

Share this post


Link to post
Share on other sites

This is an old topic, but I have found a solution - hopefully anyone facing this issue going forward can use this. 

 

1. Close FM if open

2. Go to Steam Library, right click on FM -> Properties. 

3. Untick the 'Enable the Steam Overlay...'

4. Close Steam

5. Reopen Steam

6. Go to Steam Library, right click on FM -> Properties. 

7. Tick the 'Enable the Steam Overlay...'

8. Reopen FM, editor should work now. 

 

 

 

Share this post


Link to post
Share on other sites

Hi, I bought the in game editor, it was working but then it dissapeared, tried everything suggested in this thread, but still not showing...

And now when I try to go to the downloads at the start screen, I can't, it shows this sign:

 

Thanks(I have a Mac)

 

1271857877_ScreenShot2018-07-08at12_06_08PM.thumb.png.8fcf13d92a60889e404a8705ef3ebab5.png

Edited by mario1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...