Jump to content
Sports Interactive Community
reynaldo tresor

Unable to Initialise the sound- directx error- game won't start

Recommended Posts

I just bought the game and was very excited to play this weekend.  It loaded successfully once, but since then I can't get the game to start.  It always says "Unable to initialise the sound- please check that directx is installed correctly"  I have tried the game on two computers, and I've tried all the fixes I could find online.  Please help!  Thanks

Share this post


Link to post
Share on other sites

Yes, typically in these cases it is down to compatibility settings depending on the version of Windows you are running the game on. Good to hear you got it sorted.

Share this post


Link to post
Share on other sites

Same problem here, unfortunately.  I'm running Windows 10, and have never been able to get the game to load.  I've owned it since April, and would love to try it out!

So far I've tried: changing compatibility to everything from Windows XP (Service Pack 3) through 7 and 8; running as an administrator; updating my drivers and any updates for the game; uninstalling and reinstalling Steam; and installing DirectX from an older version (I don't know why that might help, but someone mentioned having "uninstalled libs" whatever that means).  It was even mentioned that deleting everything in the games' temp file would help, but the only thing there was the keyboard configuration so I didn't bother.

So far the only result has been getting the "Unable to initialize sound" box.  Any more suggestions?

Edit: Sorry, I should mention that I've also disabled scaling, reduced the colours, and changed the resolution - although with that the only option I was given was 640x480, which wasn't mentioned as a successful solution to this problem.  Basically, I've done every option that right clicking on EHM.exe would let me try, including running their compatibility troubleshooter.  At a bit of a loss, I'm afraid.

Edited by Thursdays_Child
Incomplete information given.

Share this post


Link to post
Share on other sites

Sorry to hear that you are still having those issues. Windows 10 was not officially supported as a platform when we released and although a lot of people have run the game on Win 10 systems, there could still be some configurations where there will be issues.

You'll need to have the resolution set at least at 1024x768 to run the game (in full screen mode), but a higher res is needed to run it in a window. What is your default desktop resolution and graphics card ?

Edit: can you post a screenshot of the actual error you get when trying to start ?

Also, have you tried running the game with the command line option "-nosound" ? That should start it without enabling the sounds at all.

Share this post


Link to post
Share on other sites

I don't know how to do that (the -nosound option); the only modifications I know how to do are the options given when you rightclick on the EHM.exe file, and that isn't among the choices.  Is there another means of getting to it?  Likewise, the only graphic change I can select is 680x460.  I've included a screenshot of the properties box with the compatibility options that I've tried in it, as well as the error message when I try running it.

Hope those help you find a solution for me - I hear such great things about this game that I'd love to be able to play it!

Sc1.png

Sc2.png

Share this post


Link to post
Share on other sites

If you right-click on the shortcut in your start menu (or on your desktop) and choose properties then you'll have the opportunity to append arguments to the start command. You can also type "NHL.exe - nosound" in a run-box.

Share this post


Link to post
Share on other sites

Ah, so I have to type it in?  Thanks, I'll give that a shot!

Er... what's a "run-box"?  I really do only know how to point and click stuff, I'm afraid.  I can follow directions pretty well, though.  8)

Share this post


Link to post
Share on other sites

Right handy, that - I was wondering where that command had wandered off to between operating system updates...

Well, it's not giving me an error message, which is an improvement; but it's not doing anything else, either.  I get the "Do you want to allow this app to make changes etc." window; click "OK", and then nothing.  So I guess that's one step further along?

Tried it a few more times, and now it's giving me the "Unable to initialize sound" box again.  Hm.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...