Jump to content
Sports Interactive Community

Recommended Posts

I am having this same problem as of today.  Please tell me what to do.  I have tried everything suggested in your post about the issues.  All drivers are up to date and I do not have any security/anti-virus installed yet.  Game was downloaded today on a new laptop, and I click play and instillation goes to 1% then Steam Servers too busy Error Code (2) comes up everytime.  I have installed other games without issue.

Share this post


Link to post
Share on other sites

Okay please post your dxdiag and I'll take a look, details here - 

 

Share this post


Link to post
Share on other sites
1 hour ago, timmarkcorcoran said:

im having the same issue too. very frustrating:mad:

DxDiag.txt

Do you get exactly the same error message? What exactly happens when you try to run the game?

Share this post


Link to post
Share on other sites

@timmarkcorcoran, have just seen  that this appears to be a problem across a few games on Steam currently - I've raised this with Steam direct and will see if I can get some feedback. 

Share this post


Link to post
Share on other sites
57 minutes ago, Neil Brock said:

@timmarkcorcoran, have just seen  that this appears to be a problem across a few games on Steam currently - I've raised this with Steam direct and will see if I can get some feedback. 

Thank you Neil. I am currently reinstalling and will let you know if it works. 

Share this post


Link to post
Share on other sites
2 hours ago, Neil Brock said:

Seems to be a problem across a few games on Steam currently - I've raised this with Steam direct and will see if I can get some feedback. To confirm, are you on WIndows 10?

 I'm on Windows 7 same problem. Installs 1% then I get the error code 2. 7 hours trying to sort it and nothing works. 

Share this post


Link to post
Share on other sites

Had the same issue, but seems to be working now.

Share this post


Link to post
Share on other sites

I've been getting the same issue. Is annoying as the demo worked well, got me hooked and now I can't play the full game.

Got it to work :)

Edited by cardassian

Share this post


Link to post
Share on other sites

Yeah was a Steam problem that now appears to be fixed. Thanks for coming back and letting us know the issue is sorted for you. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...