Jump to content
Sports Interactive Community

[1.2] Direct X error after update- game won't startup.

Recommended Posts

After the recent 1.2.0f update. I am getting the old direct x error ""Unable to initialise the sound - please ensure that DirectX has been installed correctly"" the game will not start.

I've had this error in the past and it's a well known bug; community fixes include compatibility settings - or deleting your game.cfg in the temporary folders or in my previous case changing your resolution down to match the games(1024x768).

After this past update nothing works, even an old non widescreen lcd monitor which used to be able to run it native (with no finicking with settings) doesn't work anymore same error..

I have over 900hrs on steam. It would suck if this update breaks one of my favorite games.


Direct X is up to date.

I am running Windows 10 x64

I have tried all of the troubleshooting from ehmtheblueline thread on the error.

Share this post

Link to post
Share on other sites

That sounds odd. There have been no changes to the DirectX related code in this update. Have you tried removing the local content of the game from Steam and then re-installing ?

Share this post

Link to post
Share on other sites

Yes, I've tried that, I've tried removing all the temporary files as well, and reinstalled fresh multiple times.

I have tried pretty much everything I can think of besides a fresh os install

In the past I've just had to run the game with my monitor display resolution set down to 1024x768 to play the game, It would give me that same direct x error otherwise.

In the patch notes it has a lot of UI changes and one of them "- Screen drawing optimizations " makes me think maybe it has something to do with that? and how the game detects your resolution??

I am also running an AMD processor(FX8150) which I know sometimes can cause problems.

Share this post

Link to post
Share on other sites

The 1.2 patch does include a lot of UI changes but those are really just changes/additions to what is displayed on various screens. The "screen drawing optimizations " are also more high-level optimizations on caching backgrounds etc so they should not affect the low level DirectX routines at all. Do you have multiple monitors in use and what kind of native resolution do you have on your monitor/desktop ?

Have you tried removing all the temp files and then starting the game with any of the following command line arguments:

-fullscreen (to force it to start in the default 1024x768 res in full screen)

-windowed (to force it to start in the default 1024x768 res in a windowed mode, note that this requires the desktop resolution to be higher than 1024x768 due to the window borders)

-borderless_windowed (to force it to start in the default 1024x768 res in a borderless window)

Share this post

Link to post
Share on other sites

I had tried the windowed command before, I had not tried the borderless/fullscreen one.

I just cleared the files and tried it again running each of those commands separately in launch options. Still getting the same direct x error.

I tried running the commands with a different display resolution aswell to the same error.

Typically I only run one monitor which has a native display of 1920x1080, I also have another monitor which I've tried but I don't typically have hooked up, which native is 1280x1024. I have tried them both plugged in individually at a time and I still get the same error.

I have also tried all of the compatibility options before you ask. - Including disabling display scaling on high dpi settings. Which I know has fixed some peoples issues.


I have just tried running the game with a -nosound command, instead of the directx error, the game immediately quits itself.

Share this post

Link to post
Share on other sites

Version is 11.2. It's the latest supported by my gfx card.

( It's an old Nvidia 550ti gtx, Nvidia announced they were going to support DX12 for the card in a future update, but never followed through. )

I'd like to reaffirm the game worked before the patch, I played a couple days before the update but it has been broken ever since.

-It had been suggested on the steam forums for this game to 'delete all your workshop subscriptions and folders for this game'. I have tried this but the game still doesn't work.

EDIT: My GFX card drivers are fully up to date

EDIT 2: No reply from today, but I continued to troubleshoot the problem.

I installed the game on a windows 7 virtual box, the game runs without issue. ( but virtual boxes are crazy slow ) I turned off the sound in the options - saved and copied the temporary config files in appdata and moved it to my main Windows 10 EHM temp files, which I restored from the virtual box files.

Instead of a direct x error, the game quits itself after about 10 seconds. *sigh*


Later I found an earlier backed up copy of the game from ea for when I was trying a vintage database and facepack over a year ago. ( I completely forgot about it, but stumbled upon it today ) it runs without issue as it would before the 1.2 patch. - It's too old for my saves and I don't want to use an old version. But it does infact run.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...