Jump to content
Sports Interactive Community
Named

[ 15.9.0b] ECHL Salary Cap issues and crash

Recommended Posts

We have 2 errors in ECHL. First weekly salary cap game reads as yearly. Second after we import, load and start new TBL Update 7.4. Go to ECHL, take a team and click on Finances -> View -> Salary Cap Chart. After that game crash. It crash even we have salary cap defined in transfer_rules_config and without.

Share this post


Link to post
Share on other sites

Had the same exact thing happen to me today with 15.10b. Also noticed that in a number of ECHL teams I looked at, they only had a handful of players on the team, despite ECHL being set to enhanced. Not sure if this is a DB issue or not. (TBL 7.4c)

Untitled_zps67chiddn.png

Share this post


Link to post
Share on other sites

In pre-15.11b versions, if you defined a custom salary cap for this kind of league that has a weekly cap, the game read the value but assumed it to be a yearly value of the cap (as noted in the updated config file notes, the old format config files provided with some older custom database don't have the usage notes for the commands). With 15.11b, this command was expanded to check the league rules first to see if a weekly cap value was expected to be read from the config file instead of a yearly cap value. So with the latest version, you can enter the weekly cap value for this kind of league where the salary cap is defined as a weekly cap in real life.

I'm looking into the crash issue to see if it reproduces here.

Share this post


Link to post
Share on other sites

Thanks for fixed salary cap :) I tested it and when you are a GM in one of ECHL clubs and click Finances -> View -> Salary Cap Chart game not crash but when you're unemployed and click game crash.

Share this post


Link to post
Share on other sites

In version 15.12.0b my board is still restricting all my offers to $0(p/a) and league cap is $12,25k(p/a). I'm way under my budget and league salary floor. Didn´t quite understand if I´d need to do something or should this have been fixed by this new version automatically...?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...