Lucas Weatherby

Important: Skins in FM15.2

238 posts in this topic

Hello,

There are currently reports that skins from 15.1 are not selectable in 15.2. For this to work, artists need to modify and update their skins:

In FM15.1 skins you’d have this –

\skins

…\fm dark\

…\fm dark\fm dark.xml

The new format for 15.2 is now

\skins

…\fm dark\

…\fm dark\skin_config.xml

Any folder with the skin_config.xml will be discovered, and the folder name is not important anymore.

The folder name of the skin is now defined within the skin_config.xml itself with a line like this –

<string id="skin_name" value="fm dark" />

This value is important as it’s used to find a skin, and required to work in FM15.2.

In 15.2, if a skin is set, and isn’t found through the new skin discovery mechanism, it will fall back to the games default skins so any pre-existing 3rd party skin someone may be using would have their skin changed to the default until their 3rd party skin is updated, and can then be re-selected.

If any of this isn’t clear or doesn’t make sense please let me know.

Thanks,

Lucas

EDIT: To make instructions even clearer:

Step-by-Step guide for fixing non-workshop skins to work in FM 15.2

- Browse to the skins folder in your Saving Location.

- Locate the folder of the skin you are wanting to update, now open the folder for the skin you are wanting to update, for this example we will be editing the Dark Base Skin 2015 so locate this folder: base_dark2015.

- Inside the folder open the <skin name>.xml file, in this case called base_dark2015.xml

- In the xml file paste the following code into the file on the line below the name line (to make things easier):

<string id="skin_name" value="<SKIN_NAME>" />

- Now in Windows select the base_dark2015.xml file and right-click on it and select rename.

- Now with the name of the file selected copy it, in this example you should have copied the text 'base_dark2015'

- Now in the xml file on the line you pasted in before replace the <SKIN_NAME> bit with the text you have just pasted, so the line looks like this:

<string id="skin_name" value="base_dark2015" />

If done correct the middle bit of the xml file should now look a bit like this:

<!-- skin details - most of these are intentionally not translated -->

<string id="name" value="Dark Base Skin 2015" />

<string id="skin_name" value="base_dark2015" />

<string id="author" value="michaeltmurrayuk" />

Save and close the file.

- Now rename the base_dark2015.xml file to skin_config.xml

- The contents of the folder for your skin should now look something like this:

fm15.2_skinfolder.jpg

- Now load up FM and your skin should be selectable in the dropdown menu, if not turn off the skin cache and reload the current skin then reenter the preferences menu and look again.

- If you are using a Steam Workshop skin you will need to wait for the skinner to update the files for you, the Workshop should automatically update your skin once the skinner has fixed it.

- If applying for other skins replace the <skin name> and base_dark2015 bits with the name of the folder and xml file for the skin you are using, so if you are using the Dark Match Highlights Skin the skin name you want to use is 'ibh_dark2015' which is the name of the skins folder and xml file.

Share this post


Link to post
Share on other sites

Why SI??????????? You did it last year, and now you´ve done it Again. It doesn´t make sense to me. Is it because you want me to use the default skin......... NO WAY! I want my skin back. Can I change it myself?

Share this post


Link to post
Share on other sites
Can I change it myself?

This depends on whether you downloaded the skin from Steam Workshop or not.

If you downloaded the skin folders from another website then my above instructions should be all you need to update the skins so they work.

If it was downloaded from Steam Workshop then they will need to be updated for FM15.2, with these fixes.

Share this post


Link to post
Share on other sites

They are now selectable but you can't change skins. I've got all of my skins showing on preferences and when I choose any of them and click confirm, nothing happens.

Share this post


Link to post
Share on other sites

Can you try clearing the cache please in app data/roaming/local/football manager 2015 - delete the caches folder in here.

Share this post


Link to post
Share on other sites

Really....?

This isn't the first time this has happened? Why even make the change? It's like every year you make it harder for skinners...

Share this post


Link to post
Share on other sites
They are now selectable but you can't change skins. I've got all of my skins showing on preferences and when I choose any of them and click confirm, nothing happens.

Same. Skin is there, but doesn't load...

Share this post


Link to post
Share on other sites
Can you try clearing the cache please in app data/roaming/local/football manager 2015 - delete the caches folder in here.

Sorry where is this folder?

Also, this is absolutely shocking. You mean to tell us everyone will have to do this?

Share this post


Link to post
Share on other sites

i made it work... you have to replace both entries through the skinname. for flutskin it should look like this:

<?xml version='1.0' encoding='utf-8'?>

<record>

<!--

============================================================

Basic Skin Details

The commands in this file are only used to describe the skin.

Settings should be placed in the file "skins/<skin>/settings/<skin> settings.xml",

where <skin> is the name of the skin.

$DateTime: 2014/09/29 16:01:51 $

============================================================

-->

<!-- skin details - most of these are intentionally not translated -->

<string id="name" value="FM 2015 Flut Skin" />

<string id="author" value="Sports Interactive edited by FLUT" />

<translation id="description" translation_id="249669" type="use" value="Widget Set for FM2015" />

<string id="version" value="1.3" />

<flags id="parent" value="fm" />

<!--

Minimum game version this skin requires to be valid, and listed as an option in the list of skins .

This is used for two things:

- F irst of all you can force a sking to only be availble for a minimum minor release (ie patch), in other words

setting the required_version to 7.0.1 makes sure the skin won't be listed if the game is in version 7.0.0.

- Secondly, the first number ("major version") is used to decide which version the skin was designed for,

so if the version is "7.0.0" it won't be listed in the list of skins if the game version is "6.0.0." or "8.0.0",

even though 7 is less than 8.

-->

<string id="required_version" value="15.0.0" />

<string id="skin_name" value="fm2015flutskin" />

</record>

Share this post


Link to post
Share on other sites

Honestly don't see why you guys have made this decision. But yeah, anyway... tried everything in the feedback thread, changed the .xml, cleared cache, restarted game several times. Still doesn't work.

Share this post


Link to post
Share on other sites

Skin won't load too. It's on the list but it doesn't change after confirm. I cleared cash, manually and in the game.

Share this post


Link to post
Share on other sites

i delete this "fm dark" folder, how i can recover this ?

no problem now, i can use the flut skin

Share this post


Link to post
Share on other sites

Can we have an answer SI? The information provided in the opening post doesn't work. I can select my skin but it doesn't load.

Share this post


Link to post
Share on other sites
Can you try clearing the cache please in app data/roaming/local/football manager 2015 - delete the caches folder in here.

Hasn't worked at all.

Share this post


Link to post
Share on other sites

Just make sure you have both

<string id="name" value="FM 2015 Flut Skin" />

and

<string id="skin_name" value="FM 2015 Flut Skin" />

in order to make it show up when selecting skins AND being able to load the skin.

At least that was the solution for me.

Share this post


Link to post
Share on other sites
i made it work... you have to replace both entries through the skinname. for flutskin it should look like this:

<?xml version='1.0' encoding='utf-8'?>

<record>

<!--

============================================================

Basic Skin Details

The commands in this file are only used to describe the skin.

Settings should be placed in the file "skins/<skin>/settings/<skin> settings.xml",

where <skin> is the name of the skin.

$DateTime: 2014/09/29 16:01:51 $

============================================================

-->

<!-- skin details - most of these are intentionally not translated -->

<string id="name" value="FM 2015 Flut Skin" />

<string id="author" value="Sports Interactive edited by FLUT" />

<translation id="description" translation_id="249669" type="use" value="Widget Set for FM2015" />

<string id="version" value="1.3" />

<flags id="parent" value="fm" />

<!--

Minimum game version this skin requires to be valid, and listed as an option in the list of skins .

This is used for two things:

- F irst of all you can force a sking to only be availble for a minimum minor release (ie patch), in other words

setting the required_version to 7.0.1 makes sure the skin won't be listed if the game is in version 7.0.0.

- Secondly, the first number ("major version") is used to decide which version the skin was designed for,

so if the version is "7.0.0" it won't be listed in the list of skins if the game version is "6.0.0." or "8.0.0",

even though 7 is less than 8.

-->

<string id="required_version" value="15.0.0" />

<string id="skin_name" value="fm2015flutskin" />

</record>

None of the skins I have have that last command. Are you sure it's that?

Share this post


Link to post
Share on other sites

tried all suggestions and none have worked, find it rather disappointing that we are expected to do all this to get a fundamental part of the game to work.

Share this post


Link to post
Share on other sites

Lucas....Could you please upload a screen where I can see a changed config file. Because my skin does not Work with your instructions.

Share this post


Link to post
Share on other sites

i cant get it too work

i have the fm2015flutskindark skin folder inside folder i have fm2015flutskindark.xml file do i have too rename that?

then inside xml i copied

<?xml version='1.0' encoding='utf-8'?>

<record>

<!--

============================================================

Basic Skin Details

The commands in this file are only used to describe the skin.

Settings should be placed in the file "skins/<skin>/settings/<skin> settings.xml",

where <skin> is the name of the skin.

$DateTime: 2014/09/29 16:01:51 $

============================================================

-->

<!-- skin details - most of these are intentionally not translated -->

<string id="name" value="fm2015flutskindark" />

<string id="author" value="Sports Interactive edited by FLUT" />

<translation id="description" translation_id="249669" type="use" value="Widget Set for FM2015" />

<string id="version" value="1.3" />

<flags id="parent" value="fm dark" />

<!--

Minimum game version this skin requires to be valid, and listed as an option in the list of skins .

This is used for two things:

- F irst of all you can force a sking to only be availble for a minimum minor release (ie patch), in other words

setting the required_version to 7.0.1 makes sure the skin won't be listed if the game is in version 7.0.0.

- Secondly, the first number ("major version") is used to decide which version the skin was designed for,

so if the version is "7.0.0" it won't be listed in the list of skins if the game version is "6.0.0." or "8.0.0",

even though 7 is less than 8.

-->

<string id="required_version" value="15.0.0" />

<string id="fm2015flutskindark" value="fm2015flutskindark" />

</record>

skin not showing up

Share this post


Link to post
Share on other sites
i cant get it too work

i have the fm2015flutskindark skin folder inside folder i have fm2015flutskindark.xml file do i have too rename that?

then inside xml i copied

<?xml version='1.0' encoding='utf-8'?>

<record>

<!--

============================================================

Basic Skin Details

The commands in this file are only used to describe the skin.

Settings should be placed in the file "skins/<skin>/settings/<skin> settings.xml",

where <skin> is the name of the skin.

$DateTime: 2014/09/29 16:01:51 $

============================================================

-->

<!-- skin details - most of these are intentionally not translated -->

<string id="name" value="fm2015flutskindark" />

<string id="skin_name" value="fm2015flutskindark" />

<string id="author" value="Sports Interactive edited by FLUT" />

<translation id="description" translation_id="249669" type="use" value="Widget Set for FM2015" />

<string id="version" value="1.3" />

<flags id="parent" value="fm dark" />

<!--

Minimum game version this skin requires to be valid, and listed as an option in the list of skins .

This is used for two things:

- F irst of all you can force a sking to only be availble for a minimum minor release (ie patch), in other words

setting the required_version to 7.0.1 makes sure the skin won't be listed if the game is in version 7.0.0.

- Secondly, the first number ("major version") is used to decide which version the skin was designed for,

so if the version is "7.0.0" it won't be listed in the list of skins if the game version is "6.0.0." or "8.0.0",

even though 7 is less than 8.

-->

<string id="required_version" value="15.0.0" />

<string id="fm2015flutskindark" value="fm2015flutskindark" />

</record>

skin not showing up

Try adding the bolded part. That did the trick for me.

Share this post


Link to post
Share on other sites
Try adding the bolded part. That did the trick for me.

mate tried that still never worked if your using that skin could you message me the config if you dont mind

Share this post


Link to post
Share on other sites
Thanks dave and roykela

!

Ghis is the one to thank here...and dave...and Äkstjon Männ.

Share this post


Link to post
Share on other sites
mate tried that still never worked if your using that skin could you message me the config if you dont mind

Sent you a PM.

Share this post


Link to post
Share on other sites

After finally getting my custom skin to load in 15.2, I've now found that my transparent sidebar is only transparent on some screens and solid in others?

Share this post


Link to post
Share on other sites

How can I change the attribute colors for the official light skin? Where is the xml file? I don't know how to open the .fmf file... :(

Share this post


Link to post
Share on other sites
How can I change the attribute colors for the official light skin? Where is the xml file? I don't know how to open the .fmf file... :(

You can do it in game. Go to Preferences > Interface > Skin Colours and change them to your liking. Works with any skin.

Share this post


Link to post
Share on other sites
Sent you a PM.

Did you have an updated version for scorpio? If so I would be grateful for a PM as well.

Share this post


Link to post
Share on other sites
Did you have an updated version for scorpio? If so I would be grateful for a PM as well.

Nevermind. For some reason it works now...

Share this post


Link to post
Share on other sites

Hi,

I can't get Scorpio 1.6 to work. I've added the line bolded and renamed the file, so what have I missed? Thanks.

<?xml version='1.0' encoding='utf-8'?>

<record>

<!--

============================================================

Basic Skin Details

The commands in this file are only used to describe the skin.

Settings should be placed in the file "skins/<skin>/settings/<skin> settings.xml",

where <skin> is the name of the skin.

$DateTime: 2013/10/09 17:09:29 $

============================================================

-->

<!-- skin name, author etc -->

<string id="skin_name" value="Scorpio" />

<string id="name" value="Scorpio" />

<string id="author" value="wannachupbrew" />

<translation id="description" type="use" value="Scorpio skin for FM 2015" />

<string id="version" value="1.6" />

<flags id="parent" value="fm dark" />

<!--

Minimum game version this skin requires to be valid, and listed as an option in the list of skins .

This is used for two things:

- First of all you can force a sking to only be availble for a minimum minor release (ie patch), in other words

setting the required_version to 7.0.1 makes sure the skin won't be listed if the game is in version 7.0.0.

- Secondly, the first number ("major version") is used to decide which version the skin was designed for,

so if the version is "7.0.0" it won't be listed in the list of skins if the game version is "6.0.0." or "8.0.0",

even though 7 is less than 8.

-->

<string id="required_version" value="15.0.0" />

</record>

Alternatively if someone could post me the correct version that would be great also.

Share this post


Link to post
Share on other sites
Did you have an updated version for scorpio? If so I would be grateful for a PM as well.

PM sent to you.

Share this post


Link to post
Share on other sites
You can do it in game. Go to Preferences > Interface > Skin Colours and change them to your liking. Works with any skin.

You're a lifesaver! Thank you so much for replying!!!

Share this post


Link to post
Share on other sites

1: Change the config file name to skin_config.xml

2: Make sure both these strings are in

string id="name" value="Insert name of skin here" /

string id="skin_name" value="Insert name of skin here" /

With < before string id and > at the end of the line.

That should make the skins work.

Share this post


Link to post
Share on other sites
1: Change the config file name to skin_config.xml

2: Make sure both these strings are in

string id="name" value="Insert name of skin here" /

string id="skin_name" value="Insert name of skin here" /

With < before string id and > at the end of the line.

That should make the skins work.

Some may not work this way, if they don't check the required version. It should read like this:

<string id="required_version" value="15.2.0" />

Share this post


Link to post
Share on other sites
Some may not work this way, if they don't check the required version. It should read like this:

<string id="required_version" value="15.2.0" />

That might very well be.

It did nothing for me in any skins that i've tried but that does not mean it might not be important.

I've tried with 15.0.0, 15.2.0 and 15.0.2.

None of them made a difference for me.

But do give it a shot, those whose skins aren't working.

Thanks for the help ACosta :thup:

Share this post


Link to post
Share on other sites

none off the above is working for me :( tried everything roykela has suggested

Share this post


Link to post
Share on other sites

this is what i have inside my skin_config

<?xml version='1.0' encoding='utf-8'?>

<record>

<!--

============================================================

Basic Skin Details

The commands in this file are only used to describe the skin.

Settings should be placed in the file "skins/<skin>/settings/<skin> settings.xml",

where <skin> is the name of the skin.

$DateTime: 2014/09/29 16:01:51 $

============================================================

-->

<!-- skin details - most of these are intentionally not translated -->

<string id="skin_name" value="fm2015flutskindark" />

<string id="name" value="fm2015flutskindark" />

<string id="author" value="flut" />

<translation id="description" translation_id="249669" type="use" value="debut skin" />

<string id="version" value="1.0" />

<flags id="parent" value="fm dark-widgets" />

<!--

Minimum game version this skin requires to be valid, and listed as an option in the list of skins .

This is used for two things:

- F irst of all you can force a sking to only be availble for a minimum minor release (ie patch), in other words

setting the required_version to 7.0.1 makes sure the skin won't be listed if the game is in version 7.0.0.

- Secondly, the first number ("major version") is used to decide which version the skin was designed for,

so if the version is "7.0.0" it won't be listed in the list of skins if the game version is "6.0.0." or "8.0.0",

even though 7 is less than 8.

-->

<string id="required_version" value="15.0.0" />

</record>

Share this post


Link to post
Share on other sites

I have subscribed to the new Skins SI posted but i cannot use it, is not even listed as an option when i go to change. Help please.

Share this post


Link to post
Share on other sites
this is what i have inside my skin_config

<?xml version='1.0' encoding='utf-8'?>

<record>

<!--

============================================================

Basic Skin Details

The commands in this file are only used to describe the skin.

Settings should be placed in the file "skins/<skin>/settings/<skin> settings.xml",

where <skin> is the name of the skin.

$DateTime: 2014/09/29 16:01:51 $

============================================================

-->

<!-- skin details - most of these are intentionally not translated -->

<string id="skin_name" value="fm2015flutskindark" />

<string id="name" value="fm2015flutskindark" />

<string id="author" value="flut" />

<translation id="description" translation_id="249669" type="use" value="debut skin" />

<string id="version" value="1.0" />

<flags id="parent" value="fm dark-widgets" />

<!--

Minimum game version this skin requires to be valid, and listed as an option in the list of skins .

This is used for two things:

- F irst of all you can force a sking to only be availble for a minimum minor release (ie patch), in other words

setting the required_version to 7.0.1 makes sure the skin won't be listed if the game is in version 7.0.0.

- Secondly, the first number ("major version") is used to decide which version the skin was designed for,

so if the version is "7.0.0" it won't be listed in the list of skins if the game version is "6.0.0." or "8.0.0",

even though 7 is less than 8.

-->

<string id="required_version" value="15.0.0" />

</record>

Hm, not sure why it isn't working then.

Just downloaded the skin and then copied and pasted what you had here and it's working for me.

You did rename the file to skin_config?

Might be a stupid question but just making sure :D

Share this post


Link to post
Share on other sites
1: Change the config file name to skin_config.xml

2: Make sure both these strings are in

string id="name" value="Insert name of skin here" /

string id="skin_name" value="Insert name of skin here" /

With < before string id and > at the end of the line.

That should make the skins work.

I've already done this, it still doesn't work.

Share this post


Link to post
Share on other sites
I've already done this, it still doesn't work.

What skin are you using, footy1?

Share this post


Link to post
Share on other sites
What skin are you using, footy1?

I'm using Scorpio v1.6, I've posted what's in my file above. Thanks for any advice you have.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.