Jump to content
Sports Interactive Community
Maystor

FM15 3D performance

Recommended Posts

Is anyone else's game running very jerky and stuttery at high/very high settings despite the fact that the PC is powerful enough to run it smoothly? My specs are i2500K @ 4.5GHz, HD6850, 4GB RAM, SSD etc. Fresh Windows 8.1 install with latest drivers and everything. The game itself rates "this PC's 3D graphics capability" at 5 stars and yet it plays awful at anything more than "medium" settings. At high/very high as long as you can only see the pitch the game runs at constant 60fps and feels smooth. However as soon as the stadium comes into view it drops to 50fps BUT feels like 15fps for some reason. VERY stuttery. Anyone else experiencing this? It was the same in the beta, I thought it was a bug or something.

Share this post


Link to post
Share on other sites

Im also experiencing this problem even on 2d classic setting, my computer performance and speed are 4 and 5 star, and previous football managers have always worked smoothly. what could be the problem?

Share this post


Link to post
Share on other sites

It performs at a constant 60 FPS for me, but must be really bloody intensive because it puts a huge load on the GPU and pushes it to very high temps.

i7 2700K/GTX 660 Ti. Actually need to turn down the graphical settings in a FM game just so the fan isn't blaring unbearably loud.

Share this post


Link to post
Share on other sites

I wonder if it's an issue with Windows 8.1, as I have the same issue with my brand new laptop, only it isn't resolved by changing the settings. My new laptop has 2.5 stars for 3D capability and my old laptop has 1.5 stars and works fine.

Share this post


Link to post
Share on other sites

Hmm, now that you mention it, the fan on my card gets really loud at high settings as well. Seems like the load on the GPU is very high. Still doesn't explain why does the game running at ~50fps feels like it's running at 15fps at most. It's like either it's 60fps and perfectly smooth, or anything under 60fps and very laggy, basically unplayable. It's annoying because the graphics at higher settings are pretty nice whereas even medium settings look cartoonish in comparison.

Share this post


Link to post
Share on other sites

Running poorly for me too in 3D..

i7 960 3.20GHz Bloomfield Quad Core

12GB 1600MHz Triple Channel

HIS ATI Radeon 6870 1GB (latest drivers)

Share this post


Link to post
Share on other sites

Having a mare myself, 5 stars for graphics and I have to turn everything off and run on low to get a decent performance. Thought it was just my pc.

Share this post


Link to post
Share on other sites

My old laptop has 1.5 star graphics rating and the match engine works fine on default settings. My new laptop has a 2.5 star graphics rating and the ME is awfully Jittery/lags no matter what settings I change.

Share this post


Link to post
Share on other sites

Running at the highest settings and it never flinches from 60fps, I have it locked to 60 through my GPU settings, never seen the need to have higher, in the 3D match it never moves from the 60 on my laptop.

Share this post


Link to post
Share on other sites

If you havent already done so, open a thread in the relevant section of the Bugs forum and get help there.

Share this post


Link to post
Share on other sites

Mine runs well, but the game gives me 3 stars despite a system that should show 5 stars. Seems the game benchmarks me on the HD4600 Integrated Graphics, yet clearly runs on the NVidia GT740QM seamlessly. Bit disconcerting when it suddenly dropped from 5 stars in beta to 3 stars in full game, but at least it's running well.

Something worth everyone considering is Power Options. My laptop is lethargic as hell on battery. Does everything happily bar FM. For FM, it really does need AC power and even then a tweak of the power settings as HP recommended for example has a lot of power saving going on even on AC power.

Share this post


Link to post
Share on other sites
Is anyone else's game running very jerky and stuttery at high/very high settings despite the fact that the PC is powerful enough to run it smoothly? My specs are i2500K @ 4.5GHz, HD6850, 4GB RAM, SSD etc. Fresh Windows 8.1 install with latest drivers and everything. The game itself rates "this PC's 3D graphics capability" at 5 stars and yet it plays awful at anything more than "medium" settings. At high/very high as long as you can only see the pitch the game runs at constant 60fps and feels smooth. However as soon as the stadium comes into view it drops to 50fps BUT feels like 15fps for some reason. VERY stuttery. Anyone else experiencing this? It was the same in the beta, I thought it was a bug or something.

Mine was working completely fine on my brand new computer until i done the windows 8.1 update, then i got this problem so think its a problem with windows 8.1.. Anyone know a fix??

Share this post


Link to post
Share on other sites

anyone else find there graphics card runs very hot and very loud , more than when i play skyrim/borderlands 2 on highest settings

im having to play on medium settings even though it gives 5 stars

not sure if problem is my end or something with game,i have installed newest drivers

here my pc specs

fx6300

nvidia gtx 760

8gb memory

Windows 7 with all updates

Share this post


Link to post
Share on other sites

FM>Preferences>Interface Settings

Then you change rendering to 'software' instead of the setting i had it on which was 'GPU Assisted' and also unticked kinetic scrolling under rendering mode also in more interface settings.

Let me know how yous get on with that?

Share this post


Link to post
Share on other sites
FM>Preferences>Interface Settings

Then you change rendering to 'software' instead of the setting i had it on which was 'GPU Assisted' and also unticked kinetic scrolling under rendering mode also in more interface settings.

Let me know how yous get on with that?

This change will usually help with graphical issues.:thup:

Share this post


Link to post
Share on other sites
FM>Preferences>Interface Settings

Then you change rendering to 'software' instead of the setting i had it on which was 'GPU Assisted' and also unticked kinetic scrolling under rendering mode also in more interface settings.

Let me know how yous get on with that?

Does nothing for me. Wouldn't software rendering only refer to interface rendering though? Either way, my game runs either perfectly smooth at 60fps, or absolutely awful at anything under 60fps. Even 55fps lags terribly. I found turning off crowd and seats gives me 60fps at high settings but it's not a solution really. I'm going to open a thread in the bugs forum. Most games feel smooth even at 30fps, let alone 55.

Share this post


Link to post
Share on other sites

I reported this to SI already. The issue is that on high/very high details there is a comparably taxing amount of filters and shader effects enabled compared to what is technically on display -- my card that is still fine on better looking games comes to its knees too. However on medium or below everything looks totally flat, as every option that SI access under the hood is set to low values, such as the textures which make the pitches and every surface look iffy. There's no middle-ground. The game needs truly advanced graphic options, however for the time being you can fiddle around with them manually. The files are located in the directory you see in the title bar of this window:

J9ImmmL.jpg

Lots of options, none of them accessible from within the game. It is advisable to make a copy of the file you edit, just in case. And if you have trouble you can start out by editing the "medium.xml" file, which adjusts the settings for "medium" details, unsurprisingly. Already upping the "texture resolution" entry to mirror the setting of the "high.xml" file (which puts it at value "4") makes for a dramatic improvement without impacting performance or stress placed upon your video card truly any.

Share this post


Link to post
Share on other sites

Very interesting, I didn't know it was possible to tweak each settings profile. Thanks for that Svenc. I'm going to play with settings and see what happens. You have to restart the game in order for new values to take effect, right?

Share this post


Link to post
Share on other sites

It's actually pretty strange seeing people struggle with the 3D and having 5 stars while having what seems to be better systems that what I do. I have...

i7-2700K 3.5GHz

NVIDIA GeForce GTX 650 Ti Boost with 8Gig MEM

8Gig DDR 3 MEM

WIN 7 64-bit

I am playing the Demo and I have a 3 star rating but I have absolutely no problems in running everything full. Everything is really smooth.

Share this post


Link to post
Share on other sites

thank you lewylang that worked for me.

FM>Preferences>Interface Settings

Then you change rendering to 'software' instead of the setting i had it on which was 'GPU Assisted' and also unticked kinetic scrolling under rendering mode also in more interface settings.

Let me know how yous get on with that?

Share this post


Link to post
Share on other sites
finally, i found a solution that i set sync to off, anything go smooth. :applause:

"sync" ?? Explain. If you meant vertical sync it didn't work for me

Share this post


Link to post
Share on other sites
I reported this to SI already. The issue is that on high/very high details there is a comparably taxing amount of filters and shader effects enabled compared to what is technically on display -- my card that is still fine on better looking games comes to its knees too. However on medium or below everything looks totally flat, as every option that SI access under the hood is set to low values, such as the textures which make the pitches and every surface look iffy. There's no middle-ground. The game needs truly advanced graphic options, however for the time being you can fiddle around with them manually. The files are located in the directory you see in the title bar of this window:

J9ImmmL.jpg

Lots of options, none of them accessible from within the game. It is advisable to make a copy of the file you edit, just in case. And if you have trouble you can start out by editing the "medium.xml" file, which adjusts the settings for "medium" details, unsurprisingly. Already upping the "texture resolution" entry to mirror the setting of the "high.xml" file (which puts it at value "4") makes for a dramatic improvement without impacting performance or stress placed upon your video card truly any.

Tested this out by overwriting the contents of the medium file with the contents of the very high. I changed the string value to 1 yet it doesn't appear to be using very high graphics when I select medium... any idea why?

Share this post


Link to post
Share on other sites

Just splashed out on a new pc. Play the game at full graphics. No problems whastoever. Game runs smoothly. Graphics card Nvidia something or other

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...