Safc 4 eva

11.3 match engine seems slow and jerky

33 posts in this topic

last patch was fine, very fast and smooth. no problem at all

The new patch is slow and jerky on the highest 2d settings :-(

Share this post


Link to post
Share on other sites
last patch was fine, very fast and smooth. no problem at all

The new patch is slow and jerky on the highest 2d settings :-(

I have it on the highest 3D settings no issues! Occasionally get a bit of a wobble but nothing untoward. Players running on the spot. Sometimes but very rarely it can be slowish but I have many leagues and a big DB running so each saves takes up ever more mb!!

Share this post


Link to post
Share on other sites

Make sure you've got the latest drivers for you graphics card and be mindful of how many programs you have running in the background if you don't have a top-end computer. Do you know what type of graphics card you have?

Share this post


Link to post
Share on other sites

same here, medium settings, windowed mode 1920x1080 and all options on just using my i5 25oo onboard gpu and its running perfectly

Share this post


Link to post
Share on other sites
Make sure you've got the latest drivers for you graphics card and be mindful of how many programs you have running in the background if you don't have a top-end computer. Do you know what type of graphics card you have?

Not trying to be a dick, but srs, I played every single FM very smoothly (I'm actually playing FM10 right now and it's all fine). Being the FM11 system requirements the exact same as FM10, why can't I (and many people) play the game smoothly? It's obviously not a hardware problem, since with the same exact PC I can play FM10 fine and FM11 not.

Share this post


Link to post
Share on other sites

Mine is the exact opposite. My 2D match engine (prefer it tbh) is very smooth and very quick.

Loving it!

Share this post


Link to post
Share on other sites

I've has this problem with every FM11 patch and the latest still hasn't fixed it! Very very frustrating. I'm trying to update my driver as we speak, but it still doesn't explain why every other FM worked fine, including the FM11 demo and FM11 without the patches!

Share this post


Link to post
Share on other sites

11.2 ran fine for me, 11.3 is unresponsive and crashes. I brought the game based on the specs of 11.0 and I expect 11.3 to run on the same specs. Basically I have brought a game which has only ran on my PC for 3 months, this is not right and bordering on illegal, because I am on steam it seems impossible to roll back to 11.2. Quite honestly if this isnt recitfied ASAP SI have lost a loyal customer.

Share this post


Link to post
Share on other sites

It does seem slower for me as well.

My PC is only a year old and its pretty sharp.

Its not a problem as such, but I have noticed a difference since STEAM installed 11.3, yesterday.

Share this post


Link to post
Share on other sites

Try CCleaner followed by Puran Defrag for good results gents, had the two running on auto for years now - works a treat, but a manual run after installs helps heaps!

Share this post


Link to post
Share on other sites

I'm going to give it a go, fingers crossed! Although I don't really think it's going to work, I'm pretty sure theres something engrained in the patches that my system just doesn't like!

Share this post


Link to post
Share on other sites

Just to add to this point;

Prior to 11.3 - Classic 2D ME ran fine.

After 11.3 - Classic 2D ME is stuttering, isn't fluid like before.

I play on a 5 star rated machine, and oddly the 3D ME is absolutely fine and doesn't stutter at all. Just the Classic 2D I'm struggling with.

Share this post


Link to post
Share on other sites

Mine also has this problem ive dowloaded a updated driver for my graphics card and i hardly have anything running in the background.

11.2.1 the match engine ran absolute perfectly and smoothly 11.3 its jerky and freezing on me i dont understand :(

Share this post


Link to post
Share on other sites

My 3D ME was always fine till 11.3, now it sometimes becomes very slow and jerky as soon as I make any subs...strange I know, restarting the game(FM) is the only thing that gets rid of it once it starts, untill I make subs again :p.

Comp is fine, gaming setup, 8GB ram, good G card etc so its not that. (Geforce GTS450)

Share this post


Link to post
Share on other sites

Mine now since closing MSN and also upgrading my graphics card drivers will start jerky but then it will run smoothly its not perfect but it will do

Share this post


Link to post
Share on other sites

Yes I noticed that at the beginning of a game it is jerky then smooths out. No freezing except i get that situation where the players run at a standstill for about 10 secs then the game continues.

Share this post


Link to post
Share on other sites

This happens easily after any new install.

Any gamer worth his (or her) salt knows you need a little clean after a couple of hundred MB's of patch have been dumped in there. Not to mention all the temp file crap that builds up whilst installing.

Got no issues here btw.

Share this post


Link to post
Share on other sites
This happens easily after any new install.

Any gamer worth his (or her) salt knows you need a little clean after a couple of hundred MB's of patch have been dumped in there. Not to mention all the temp file crap that builds up whilst installing.

Got no issues here btw.

Thanks for that, but a clean install and disk defrag and ensuring I have upto date drivers the game is no better. Although obviously I did all that before posting honest guv

Share this post


Link to post
Share on other sites

Having the same problem with 3d, before this patch game use to run perfectly :(

Share this post


Link to post
Share on other sites

i have an i7 950 ati hd 5870 6gb ram win7 and no programs running in background etc. i have noticed a number of times where the game freezes while playing a match and the players run on the spot for between 5-15 seconds. one time i had to jump out to windows and jump back in before it started again. strange as the game runs fine apart from these pauses..

Share this post


Link to post
Share on other sites
i have an i7 950 ati hd 5870 6gb ram win7 and no programs running in background etc. i have noticed a number of times where the game freezes while playing a match and the players run on the spot for between 5-15 seconds. one time i had to jump out to windows and jump back in before it started again. strange as the game runs fine apart from these pauses..

that happened in 11.2 occasionally too.

Share this post


Link to post
Share on other sites
the new ME runs smoother than my ass cheek. It's almost perfect.

me too ........

Share this post


Link to post
Share on other sites

The ME ran smoothly in 11.2 and runs just as smoothly in 11.3!

Share this post


Link to post
Share on other sites

Force the game to run windowed, it's the only way I can ditch the jerky 3D graphics.

Share this post


Link to post
Share on other sites

how do you get it to run windowed? is it in preferences because i cant see it! or do you go to properties on fm.exe? thanks for any help

Share this post


Link to post
Share on other sites
how do you get it to run windowed? is it in preferences because i cant see it! or do you go to properties on fm.exe? thanks for any help

It might be greyed out. If it is then create a desktop shortcut if you dont already have one. Right click on it and select properties. Look for the shortcut tab and in the target box type -windowed -small_screen so it looks like this

"C:\Program Files (x86)\Sports Interactive\Football Manager 2011\fm.exe" -windowed -small_screen

Click apply then reboot your computer. When you restart fm it should be in windowed mode.

Share this post


Link to post
Share on other sites
It might be greyed out. If it is then create a desktop shortcut if you dont already have one. Right click on it and select properties. Look for the shortcut tab and in the target box type -windowed -small_screen so it looks like this

"C:\Program Files (x86)\Sports Interactive\Football Manager 2011\fm.exe" -windowed -small_screen

Click apply then reboot your computer. When you restart fm it should be in windowed mode.

thanks very much i will give that a try

Share this post


Link to post
Share on other sites

when i click apply it says its not valid, help???

Share this post


Link to post
Share on other sites

I have the same problem , windowed mode works but it's not a real solution.. does anyone knows a fix so that we can play in fullscreen without those jerky and stuttering matches ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.