Sign in to follow this  
Followers 0
buceph

Firmware

18 posts in this topic

Is there any information on what firmware will be needed to run FM? I'm after getting used to playing SNES games on the PSP.

Share this post


Link to post
Share on other sites

Is there any information on what firmware will be needed to run FM? I'm after getting used to playing SNES games on the PSP.

Share this post


Link to post
Share on other sites

Anyone willing to answer? An official, "Don't know" is probably most like, but even still I'd like to see it.

Share this post


Link to post
Share on other sites

To be honest I don't know off-hand, its not something which we have to specify ourselves.

Because of this I'd expect the answer to be 'along the lines of that required by any other game released today' (because I presume Sony does the same for all new games) .....

I will try and find out specifics for you in the next few days.

Share this post


Link to post
Share on other sites

Your PSP will need to be running the 2.5 firmware for FM Handheld to work I'm afraid.

Share this post


Link to post
Share on other sites

Will the 2.5 firmware come with the game?

I ask, as some games and UMD films have the required firmware on them so you can upgrade if requird.

Share this post


Link to post
Share on other sites

Judging from other releases, Sony tend to bundle the latest firmware, so it'll probably come with the option to upgrade to the 2.6 firmware.

Share this post


Link to post
Share on other sites

Sorry to up an old thread, but I just came on here to ask this question.

Thats me out of buying FM I'm afraid, I know its probably out of SI's hands - but im a happy 1.5 user and the features of homebrew mean I wont be upgrading.

Snes / Megadrive > FM Handheld.

I would have loved to have bought the game, but I dont want to lose features like homebrew, emu's and video players like PMPMod that let me stream video to my PSP from my PC.

icon_frown.gif

Share this post


Link to post
Share on other sites

So you are ruling yourself out of any future PSP games (as the requirements will always be incrasing) to run some crappy emulation. Amazing that some people take this attitude imo

Share this post


Link to post
Share on other sites

<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by EdL:

So you are ruling yourself out of any future PSP games (as the requirements will always be incrasing) to run some crappy emulation. Amazing that some people take this attitude imo </div></BLOCKQUOTE>

'tis Woodseys decision, at some point in the future he might change his mind, then again perhaps not - 'tis entirely his right imho.

Share this post


Link to post
Share on other sites

Never bothered with homebrew or anything like that. Like my machine to be up to date icon_cool.gif

Share this post


Link to post
Share on other sites

<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Marc Vaughan:

<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by EdL:

So you are ruling yourself out of any future PSP games (as the requirements will always be incrasing) to run some crappy emulation. Amazing that some people take this attitude imo </div></BLOCKQUOTE>

'tis Woodseys decision, at some point in the future he might change his mind, then again perhaps not - 'tis entirely his right imho. </div></BLOCKQUOTE>

Maybe, but I can't understand buying a £200+ PSP to use for that

Share this post


Link to post
Share on other sites

EDL - I bought my PSP as an iPod, Archos and portable games machine.

I dont just use it for games, I use it to play movies, listen to music, store pictures etc.

I'd rather have the ability to stream movies, listen to the radio over wi-fi etc ASWELL as play games.

At the moment, in my opinion, these features are more of a benefit to me than just the ability to play FM..after all, I have it on my laptop and *probably* on my 360.

Its just a shame that Sony have to force these updates to stop the minority that use it for playing ISO's of games they dont own.

Share this post


Link to post
Share on other sites

Fair enough, but I'm not really making a case for just FM - any new game you are not going to able to play, for me the main reasoon for the psp is the games.

I have seperate devices for each, have a couple of mp3s on the psp but not many, prefer to use my Zen

Share this post


Link to post
Share on other sites

I like the idea of the homebew games and other 'perks' that come with 1.5 but I personally upgrade when ever possible as it means I can play the latest games and use the latest features of the PSP.

Share this post


Link to post
Share on other sites

I know I will have to upgrade eventually, hopefully version 3.00 will have some usefull features, this will give me enough time to save up for a 60GB Archos to store movies and music on.

Share this post


Link to post
Share on other sites

There are means and ways of getting the majority of homebrew apps to work on firmware 2.0+...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.