snazzypuppy

FM09 graphics were nice an smooth for me, but FM10 are all jerky?

12 posts in this topic

Apologies if this has been answered in another thread, I've had a look around but can't find the answer:confused:

As the title says, FM09 ran nice and smooth on my PC. FM10, however, is all jerky and laggy during match play, which is making playing the game frustrating to say the least (although loving all the other parts of the game!!:thup:). It's confusing as all the blogs say that if FM09 worked on your PC, then FM10 will.

Is anyone else experiencing this? I have played around with the options for display, but didn't really make a difference. FYI - my computer specs are: processor - PentiumD 920 (P) DC 2.8 GHz, graphics card - GeForce 6200SE, 64 MB DDR memory

thanks for your help!:cool:

Share this post


Link to post
Share on other sites

Have you got your settings turned all the way down? Your computers at the low end in every department.

Share this post


Link to post
Share on other sites

cheers for the replies guys - really appreciate the help. looks like I am going to have to get a new PC at this stage. there I was thinking my PC could still hold its own!

have turned down the settings and have updated the driver on my graphics card, but not directx, so will do that. just thought it was strange that I had no probs running FM09 as recent as last week! hopefully directx is a good temporary fix.

Share this post


Link to post
Share on other sites
I was the same - pre-ordered FM10 on the basis that 'if 09 ran smoothly on your laptop, so will FM10'. Feel a tad let down by the fact that its unbearably jerky on 3D. Even the 2D isn't very smooth. Will there be any improvements in the full version / any chance its some sort of bug?? And my graphics card cannot be updated. I've visited all the websites and contected the manufacturer, its impossible to upgrade it. My laptop's 3 years old, but I don't see that as a reason why i should need a new one to play a game that i love!

I hear ya! glad I'm not the only one - maybe on release it will be better?;)

Share this post


Link to post
Share on other sites

just quickly on this, the directx link above could not be found. is it this that I need to update?:

DirectX End-User Runtime Web Installer

Brief Description

August 2009

The Microsoft DirectX® End-User Runtime provides updates to 9.0c and previous versions of DirectX — the core Windows® technology that drives high-speed multimedia and games on the PC.

Share this post


Link to post
Share on other sites
just quickly on this, the directx link above could not be found. is it this that I need to update?:

DirectX End-User Runtime Web Installer

Brief Description

August 2009

The Microsoft DirectX® End-User Runtime provides updates to 9.0c and previous versions of DirectX — the core Windows® technology that drives high-speed multimedia and games on the PC.

http://www.microsoft.com/downloads/details.aspx?familyid=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en

try this one and yes august 2009 is the one you need :)

Share this post


Link to post
Share on other sites

Hello everyone,

Celebrating my first post with a rather stupid mistake that i made.

I wanted to upgrade my Grapic card driver and downloaded from the Nvidia website - every thing was going as planned, until i by mistake uinstalled my grapic card instead of only the old driver. Is there any way to fix this?

Windows XP

Intelcore2 Duo CPU T5550 1,83Ghz, 2,0GB RAM.

Graphic Nvidia GeForce 8200 G

All help is much appriciated!

Thanks

Share this post


Link to post
Share on other sites

Unless you physically unplugged the card, simply running the latest driver installer from nvidia's website for your card and rebooting should set things right.

Share this post


Link to post
Share on other sites
Unless you physically unplugged the card, simply running the latest driver installer from nvidia's website for your card and rebooting should set things right.

Thanks for the quick reply :-)

Share this post


Link to post
Share on other sites

The first thing you guys can try is switching off the crowd to see if that helps. After that, if you are still having performance issues, try switching off the stadiums too.

If you don't particularly use sound, then switch that off also. All these things can help boost the performance of the actual match experience.

Share this post


Link to post
Share on other sites
The first thing you guys can try is switching off the crowd to see if that helps. After that, if you are still having performance issues, try switching off the stadiums too.

If you don't particularly use sound, then switch that off also. All these things can help boost the performance of the actual match experience.

cheers Neil:thup: actually, that could be it. I always listen to music through itunes when playing, but always had sound turned off in FM09. In FM10 I had left it on - maybe that's why it got a bit funky:rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.