Jump to content
Sports Interactive Community
Lucas

Tip: Macs and Using full screen while windowed

Recommended Posts

Just a little tip, not done a search but hey presto, thought it was a good little thing I found out the other day (very late into FM09 days), but here goes:

Situation

Do you use a Mac, MacBook or MacBook Pro with a resolution like 1280x800? (the maximum for the 13" model)

Do you find that the bottom of the screen tends to be cut off forcing you to go into Full Screen mode because of the Mac taskbar? ... and it annoys you?

How do you then, get the best of your screen, without forcing you to go into Full Screen mode - so you can switch applications quickly without the screen having a fit because you're playing FM in full screen?

Solution

The solution, is followed:

1) Open Finder

2) Go to Applications (Usually found under the "Places" pane)

3) Go to Sports Interactive -> Football Manager

4) Right click FM, and you should see amongst the options:

Show Package Contents

5) Inside the "Contents" folder in the finder window, you will see a file, and a couple of folders.

6) Open "info.plist" with TextEdit (comes with the MacOS)

*REMEMBER TO BACK UP THE FILE IN CASE YOU DO THIS WRONG OR IT MAY RESULT IN FM NOT WORKING

You should now see in the TextEdit program, something like this:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleDisplayName</key>

<string>Football Manager 2009 v 9 . 3 . 0 f 36280</string>

<key>CFBundleDocumentTypes</key>

<array>

....

7) Under '<dict>' Press Enter (Return) and put the following:

<key>LSUIPresentationMode</key>

<integer>4</integer>

8) It should now look like this:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>LSUIPresentationMode</key>

<integer>4</integer>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleDisplayName</key>

<string>Football Manager 2009 v 9 . 3 . 0 f 36280</string>

<key>CFBundleDocumentTypes</key>

<array>

....

9) Save the file, and run FM.

10) You will now notice FM makes full use of the screen, yet its still technically in windowed mode, making transitioning and switching programs much more seamless.

Ideally, SI would include this anyway as part of the Mac installation, but they don't. I found this through looking on the internet and its really improved my gaming and multi-tasking.

Any Questions or problems, let me know. I can email and send you the replacement info.plist file so that your Mac dock and taskbar will remain hidden, and there are no problems.

You can of course, use this method for any other program too, so good luck.

Share this post


Link to post
Share on other sites
Just a little tip, not done a search but hey presto, thought it was a good little thing I found out the other day (very late into FM09 days), but here goes:

Situation

Do you use a Mac, MacBook or MacBook Pro with a resolution like 1280x800? (the maximum for the 13" model)

Do you find that the bottom of the screen tends to be cut off forcing you to go into Full Screen mode because of the Mac taskbar? ... and it annoys you?

How do you then, get the best of your screen, without forcing you to go into Full Screen mode - so you can switch applications quickly without the screen having a fit because you're playing FM in full screen?

Solution

The solution, is followed:

1) Open Finder

2) Go to Applications (Usually found under the "Places" pane)

3) Go to Sports Interactive -> Football Manager

4) Right click FM, and you should see amongst the options:

5) Inside the "Contents" folder in the finder window, you will see a file, and a couple of folders.

6) Open "info.plist" with TextEdit (comes with the MacOS)

*REMEMBER TO BACK UP THE FILE IN CASE YOU DO THIS WRONG OR IT MAY RESULT IN FM NOT WORKING

You should now see in the TextEdit program, something like this:

7) Under '<dict>' Press Enter (Return) and put the following:

8) It should now look like this:

9) Save the file, and run FM.

10) You will now notice FM makes full use of the screen, yet its still technically in windowed mode, making transitioning and switching programs much more seamless.

Ideally, SI would include this anyway as part of the Mac installation, but they don't. I found this through looking on the internet and its really improved my gaming and multi-tasking.

Any Questions or problems, let me know. I can email and send you the replacement info.plist file so that your Mac dock and taskbar will remain hidden, and there are no problems.

You can of course, use this method for any other program too, so good luck.

Hi

I have the same problem with my Acer Aspire 5738G. Can I apply the same solution to my computer?

Share this post


Link to post
Share on other sites

I assume you're using Windows... So no. But fear not.

What you need to do is right click your FM shortcut, and in the Target field, before the last ", add:

" -small_screen -windowed"

of course don't add extra quotation marks.

My solution might be wrong, in which case go back and add the small_screen and windowed commands after the " ".

Failing that, a search on these forums will give you the correct solution I'm sure.

It won't mess up your FM doing this, this way.

Much safer and easier with Windows.

If you've activated via Steam, then I'm not sure what the solution is there.

Someone correct me if I'm wrong, but I'm trying to help.

Thanks for finding this thread, always nice to see ;):)

PS: As what you're using I assume is a netbook(?), you might also find it useful to head to the Skinning Hideout for some Netbook skins....

There is one available here, NetBook2010. Should help you with the screen clutter. :thup:

Share this post


Link to post
Share on other sites
I assume you're using Windows... So mo. But fear not.

What you need to do is right click your FM shortcut, and in the Target field, before the last ", add:

of course don't add extra quotation marks.

My solution might be wrong, in which case go back and add the small_screen and windowed commands after the " ".

Failing that, a search on these forums will give you the correct solution I'm sure.

It won't mess up your FM doing this, this way.

Much safer and easier with Windows.

If you've activated via Steam, then I'm not sure what the solution is there.

Someone correct me if I'm wrong, but I'm trying to help.

Thanks for finding this thread, always nice to see ;):)

I am using steam and i have tried using " -small_screen -windowed". Sure enough it opens in windowed mode, but I still can't see the bottom of the screen. It is annoying me very much:(

I have looked through the forum, but I am not able to find any solutions to this problem.

Share this post


Link to post
Share on other sites

Reduces FM's screen dimensions (forces them actually) to run on smaller screens.

Which is possibly and probably why you are experiencing the problem with the cutoff. I would suggest downloading the NetBook skin in my edited post above and giving that a go with the same commands (small_screen / windowed). Setting your taskbar to autohide as well will help a little bit also, I should have mentioned!

Share this post


Link to post
Share on other sites
Reduces FM's screen dimensions (forces them actually) to run on smaller screens.

Which is possibly and probably why you are experiencing the problem with the cutoff. I would suggest downloading the NetBook skin in my edited post above and giving that a go with the same commands (small_screen / windowed). Setting your taskbar to autohide as well will help a little bit also, I should have mentioned!

It is a nice skin, but it doesn't solve the problem. So I will just auto hide the task bar. Maybe SI will come with at solutions in the future.

Anyways thank you for your help.

Share this post


Link to post
Share on other sites

I know this is old, but on fm10 my screen is still cut off after doing what you said.

this is what mine looks like

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>LSUIPresentationMode</key>

<integer>4</integer>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleDisplayName</key>

<string>Football Manager 2010 v 10 . 3 . 0 f 104782</string>

<key>CFBundleDocumentTypes</key>

<array>

<dict>

<key>CFBundleTypeExtensions</key>

<array>

<string>fm</string>

</array>

<key>CFBundleTypeIconFile</key>

<string>document</string>

<key>CFBundleTypeName</key>

<string>Saved Game</string>

<key>CFBundleTypeRole</key>

<string>Editor</string>

</dict>

Any help would be great..I think i fixed it in 10.2, but after updating to 10.3 it did it again..I forgot how I fixed it last time.

Share this post


Link to post
Share on other sites

It does work, yes. Follow the instructions above, it is all the same.

Share this post


Link to post
Share on other sites

For people like me who installed with Steam.

You can locate FM.app in:

<your home folder>/Application Support/Steam/SteamApps/common/football manager 2011

And then follow the instructions above. I've just tried it so will report back on if it works or not.

EDIT: IT WORKS

Share this post


Link to post
Share on other sites
anyone got this working on FM11' date=' i cant get it to work on 11.3?[/quote']

Users of this should be aware they have to reapply the changes in the original post after each patch.

Do it again and it will work.

Cheers.

Share this post


Link to post
Share on other sites

I'm running 11.3 and mine looks like this, and doesn't work. Any more help?

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>LSUIPresentationMode</key>

<integer>4</integer>

<key>CFBundleExecutable</key>

<string>run.sh</string>

<key>CFBundleIconFile</key>

<string>shortcut.icns</string>

<key>CFBundleInfoDictionaryVersion</key>

<string>1.0</string>

<key>CFBundlePackageType</key>

<string>APPL</string>

<key>CFBundleSignature</key>

<string>????</string>

<key>CFBundleVersion</key>

<string>1.0</string>

</dict>

</plist>

Share this post


Link to post
Share on other sites

mine worked after i closed everything, although is there any thing that you can change so the height is smaller?

Share this post


Link to post
Share on other sites

Great Stuff, I think it was around in versions ago.

I run a 27" I mac - lovely 2 windows side by side, i am in love.

Share this post


Link to post
Share on other sites

Does anyone know if this method still works? I have used it to great effect on fm 12, but just tried it on fm 13 on the same notebook but it isn't working.

I'm on the latest version of OS X Lion.

Share this post


Link to post
Share on other sites

It's working for me, having just got my MacBook back and trying this out.

Share this post


Link to post
Share on other sites
You guys don't have the green + on your macs?

Obviously we do, but using it in windowed mode causes the bottom of the window to be cut off, as stated in the OP.

Share this post


Link to post
Share on other sites

Just wanted to add my experiences as I´ve used a couple of hours to solve my challenge; playing FM 2013 on a Macbook Air 11" in windowed mode so I can cycle through desktops with my windows open. The results are based upon findings in this thread, albeit from many different posters. It would´ve saved me some work if all was collected in a single post.

I´m currently on OS X Mountain Lion with Football Manager 2013 through Steam. And it works :-)

1. Show hidden files on the Mac

How to: http://www.mikesel.info/show-hidden-files-mac-os-x-10-7-lion/

2. Go to your Steam directory and find the fm.app

The fm.app file is located here:

Harddrive/Users/<your username>/Library/Application Support/Steam/SteamApps/common/football manager 2013/fm.app

3. Do as the opening post states.

Right click fm.app, show page contents, edit info.plist by finding <dict> and then adding the following straight after that:

<key>LSUIPresentationMode</key>

<integer>4</integer>

Save the file (cmd+s) and close it.

4. Enable small screen mode on FM

Launch Steam, go to the Games Library, right click "Football Manager 2013", chose properties. Then click "Set launch options", type in:

--small_screen --windowed

Press OK, then close.

5. Launch FM through Steam by clicking Play.

6. Press the green maximise button, and the bottom corner narrows down.

You´ll notice that the bottom is out of the desktop, thus you won´t be able to resize the window. Press the maximize button on the FM window, and the window will scale to fit the screen.

7. Resize window so it fits your screen nicely.

The window probably won´t maximize your screen real estate, so move the window to the top left of the screen and resize by dragging the bottom right corner so the window fills the screen nicely. OS X remembers how you placed your window, so when you´ve done it one time it´ll remember it next time.

8. Game on.

The final piece before getting the window maximised is removing the title bar, albeit I haven´t figured a way to remove this one. Following these steps will make FM very well playable on a 11" screen.

If you really want a better overview and less scrolling you could use Michael Murrays Netbook 2013 Skin for FM. It removes padding and margins, even though I felt the screen became very cramped, it certainly gives a much better use of the space available on the screen

http://michaeltmurrayuk.blogspot.no/2013/02/netbook-2013-skin.html

As for the gaming experience on a Macbook Air 11" (mid 2013) - it´s great!

Hope this is useful for someone.

Cheers,

haaX

Share this post


Link to post
Share on other sites

Step 4 should be enough to do it anyway, without the need to change the .plist.

Share this post


Link to post
Share on other sites

Removing the top as through steps 1-3 gives you 30 px extra or something, which makes for less scrolling. Do you know if it´s possible to remove the title bar as well?

Share this post


Link to post
Share on other sites

So the only way I can get FM13 to be playable in windowed mode is by hiding the task bar.

Ideally I want to change the size of the window so the full game sits above the task bar, ive a 13" Macbook Pro btw. I've tried the two methods above, both changing the textedit file and also that line within steam but there is no noticable difference when I do either...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...