Jump to content

Recommended Posts

Hey SI Support & Community,

I hope you are all safe and well.

I know that technical issues should be submitted via the SEGA ticketing facility, however, I was told:

Quote

 

As you may know, SEGA is the publisher and Sports Interactive is the developer. SI directly moderates these forums so it is the fastest way to get information directly to the developers. At SEGA Support our main focus is on assisting with technical and activation related issues that are preventing people from playing the game. We definitely appreciate the feedback and just want to ensure that it gets to the right place as quickly as possible.

 

My friend has recently purchased FM 2021 to join our Online Save which is now 7 seasons in. The problem is that he cannot get past the "Loading Online Game..." prompt upon entering the password.

This appears to be a relatively common issue with no clear solution. Therefore, if anyone has any ideas and the time to share some potential solutions it would be much appreciated. I will briefly explain the situation and list the fixes we have attempted.

–––––––––––––––––––––––––––––––––––––––––––––––––––––

Issue:

I host an Online Game which is now 7 seasons in with a friend through Steam; when our other friend joins he is stuck on a 'Joining Online Game...' screen which does not budge no matter how long you leave it. To be clear, he can find the server via the Join Online Game search function.

–––––––––––––––––––––––––––––––––––––––––––––––––––––

Attempted Solutions:

• Restarted FM 2021

• Restarted Steam

• Restarted Computer (Windows)

• Turned off Windows Defender & Anti-Virus Software

• Uninstalled the Game and Reinstalled

• Checked Graphics Card Drivers were Updated

• Attempted Joining through Steam Invites

• Logged into & out of Epic Games

• Deleted Epic Games Launcher

• Deleted & Reinstalled Steam

• Checked Steam 'regions'/'download regions'

• Cleared Cache & Preferences

• Deleted Cache & Preferences Folders

• Verified Game Files via Steam

• Reset Router

• Run Steam and FM 2021 as Administrator

• Tried to get him to host, neither of us could get into his server; likewise my other friend tried both hosting and joining him - no luck

   - We each created brand-new saves respectively when attempting the above

• The friend could not join open servers either - encountered the same problem.

• Changed in-game preferences to allow 'Anyone' to join and removed a password.

• Ensured we are all fully updated with FM 2021 and on the same version.

• Tried continuing a couple of days in-game to see if it would process him in?!

• Forwarded ports in Router Settings.

• Manually assigned Google DNS (4.4.8.8/8.8.8.8)

• Disabled IPv6

• Uninstalled VPN

• Restarted Wireless Network Adapter (TP-Link)

• Tried Hotspotting from his Cellular Network

• Edited/Created registry keys potentially affecting DHCP

• Cleared the Computer's Cache's and cleaned his registry with CCleaner

• Tried inviting him from the Steam overlay/menus

• Ensured he was searching for the exact server name

–––––––––––––––––––––––––––––––––––––––––––––––––––––

Relevant Misc. Info:

Host is running on Mac OS, the other participant who can, and always has connected with no problems is on Windows. The friend who cannot join is on Windows too.

He has a USB Network Adaptor.

The friend who cannot join never receives an error message. Just an infinite "Joining Online Game..." prompt. He only receives an error message when joining via a Steam invite - "Unable to connect to game".

The logs do not appear to show any clear issues.

We have been attempting the above solutions over the past week in suspicion that time would solve the issue (especially if the servers were a bit iffy), but it does not appear that any time will heal this.

Another relevant point is that he had no issue connecting to us on FM 2020 last year.

–––––––––––––––––––––––––––––––––––––––––––––––––––––

He can play anything else with us without an issue. So we're pretty stumped with this one.

Any help would be much appreciated!

Thanks in advance!

Link to post
Share on other sites

I have uploaded our Save in anticipation that I may have been asked to sooner or later. File Name: Louis Connor - Southend United; uploaded at 9:30am, 11/01/2021.

Edited by louismcleodconnor
Link to post
Share on other sites

Update:

As I said, I am trying to keep this updated with our attempted solutions in order to help others encountering the same problem listed above.

We have conducted a range of network trace samples on what is actually happening behind the scenes when attempting to join a series of different online games. After spending multiple fun hours analysing network packets, we have arrived at two different potential solutions although they are by no means conclusive as there didn't seem to be any evident errors and we are definitely not experts in networking. There may be no errors because the client never actually fails to connect, it just seems to be in a state of network loop across two networking channels?!

1. There is potentially an issue resolving DNS. We will be allocating a manual Primary and Secondary DNS this evening.

2. The Wireless Adapter seems to be playing a bigger part in this or there is potential interference from a VPN that is turned off but installed on the computer. The connection or attempt to connect to what we assume is the network game server appears to keep jumping between IPv6 and IPv4 channels. As far as we can tell, the network communicates via IPv4 on the successful connection where the online game loads successfully. We will try uninstalling the VPN, disabling IPv6 and giving it another whirl! Last option is moving his desktop computer to the router and plugging in the good ol' ethernet cable!

We will give these a go this evening! If these don't work we will probably rule out networking as an issue, although we look forward to receiving advice!

Edited by louismcleodconnor
Link to post
Share on other sites
28 minutes ago, zamora8.9 said:

I'm having the same issue, tried most of the things you tried without luck, please let me know if find a fix...

This does seem to be relatively common with no fix! I'm currently trying to rule out network issues on our end. Can you confirm whether you are connected via wired or wireless? As mentioned earlier: Manually assigning DNS, disabling IPv6 and uninstalling his VPN have not solved the issue.

He is not in a position to move his computer closer to the router to connect via Ethernet until the weekend. However, the fact that my friend can discover games and that we're almost at the end of troubleshooting options for networking is making me think it could be a memory or processing issue. I'll have to brainstorm.

He does not have another device which he can download FM 2021 on and attempt to run Online Games on. I'm somewhat determined to get to the bottom of this as I love FM. It's my favourite game series by far and it is made even better playing with friends. Hopefully we can achieve this soon, @zamora8.9!

Link to post
Share on other sites
2 hours ago, zamora8.9 said:

We both can connect to other games hosted by random people but not when one of us is hosting. I tried ethernet and wireless and two different networks, nothing worked.

This suggests that it is not a Network problem unless you and your friend have Strict NAT Types. Opening the ports to Football Manager on your routers may be a solution? I'm not an expert so please take my advice with a pinch of salt! It is strange that you can join other people but not each other; perhaps one of you has accidentally blocked the other? :lol:

I have analysed some more Network Traces tonight. My friend has a lot of re-transmitted packets; a lot of 'ACK' (acknowledge) issues suggesting high packet loss and lost data. It appears that when he attempts to join our game he is communicating with four different Amazon Web Servers at once; which I would assume are Steam Servers? On my successful trace I only communicate with one at any time. I have no idea where I would start delving deeper into this information or find an explanation as to why his machine is communicating with multiple different servers and making very little progress.

He is on Sky Broadband which has a negative reputation among my friends. I wonder if there is any correlation with anyone else? Saying this, the one friend that can connect without an issue is also with Sky - just in a different area!

This evening we're going to focus on his computer: attempt to update his Network Adaptor Drivers, let CCleaner loose to repairing his registry files and have a snoop around. We're also going to run a 'ProcMon' a.k.a Process Monitor - which I'm slightly dreading as from previous experiences with system process analysis, these things tend to be huge! With any luck it will hopefully reveal some processing errors and highlight an easy fix!

I'll update with our findings!

Edited by louismcleodconnor
Link to post
Share on other sites

I manually updated the network adaptor driver, cleaned up the reg files with CCleaner and gave ProcMon a go. Overall, this was inconclusive and we did not solve our issue. I'm truly stumped.

Results from our Process Monitor:

• RegQuery - NAME NOT FOUND

"HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{35a08594-7f8b-11ea-8fc8-806e6f6e6963}\EnableDhcp"

This process within FM.exe cannot be executed as it cannot be found. This is a repeated error throughout the trace.

667062377_Screenshot2021-01-16at20_09_03.thumb.png.7bedefc628e4508f97af56604a3ca4c6.png

–––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

Attempted Solution:

I attempted to create the missing key. This was successful but it did not solve our issue of not being able to join the Online Game.

–––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

When looking into the local Firewall settings, Football Manager 2020 had pre-installed inbound and outbound rules whereas Football Manager 2021 did not. This confused me a bit, but is unlikely to be the cause of this issue as all Firewalls were turned off. Although it did make me think this is why he could play FM 2020 without issue.

I think it may be Steam's side of things. I have double checked the port forwarding for Steam is active and enabled as well as ensuring all privacy settings are clear of gameplay. Still no luck. The issue is that I cannot contact Steam support; when chasing FM issues I get sent to SEGA... who sent me here.

It's coming up to this threads one week anniversary. If any moderators were able to comment or point me in the right direction that would be great - we're currently considering a full format of his machine but it would be a shame to waste even more time if it does not fix the issue!

Edited by louismcleodconnor
Link to post
Share on other sites

Hi @louismcleodconnor

Very sorry its taken a while to reply to this post. Thank you very much for all the information you have sent and the save. I will forward this thread to members of the team who will look into this for you. You have pretty much gone above and beyond trying to sort the issue out your end so we will do our best at our end to sort the issue out for you. As soon as we have more information we will post it here for you. 

Thanks 

 

Link to post
Share on other sites
Just now, John Kendall-Torry said:

Hi @louismcleodconnor

Very sorry its taken a while to reply to this post. Thank you very much for all the information you have sent and the save. I will forward this thread to members of the team who will look into this for you. You have pretty much gone above and beyond trying to sort the issue out your end so we will do our best at our end to sort the issue out for you. As soon as we have more information we will post it here for you. 

Thanks 

 

Many thanks @John Kendall-Torry. I'll keep an eye out for a reply from the relevant team. Have a great evening and stay safe!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...