Jump to content

Not signing into my google play profile when starting game up, unable to earn or view achievements


Recommended Posts

Device is a Galaxy tab s6 and running Android version 10. When I start the game I get the ‘connecting to play games’ notification but the screen just blinks and a white box is there asking for me to pick an account.

I proceed to choose google account but still doesn’t sign my google game profile in. This means I can’t earn in game achievements and if I click on achievements in game menu screen just blinks and does nothing.

I have rebooted the tablet and uninstalled and reinstalled game and nothing is working. I want to be able to earn achievements as my friend also has the game on Galaxy tab s7 plus and is able to earn achievements 
 

Link to post
Share on other sites

Hi @brid81,

Thanks for contacting us.

A workaround for this should be as follows: uninstall FMT21>Google Play Setting (should be three dots in top right hand corner of google play)>Scroll down & Clear Local Search History > Delete Games account and data > Re-enter google play > Sign if prompted (if not then re-install the game and launch). You should then be prompted to sign into your desired account anyway upon launch > sign in > Achievements should open as intended. Let me know if this hasn't solved your issue and i can escalate it with devs.

Cheers,

Harry

Link to post
Share on other sites

Hi Harry. I have already deleted and reinstalled the game and gone through the clearing cache for play store, play games app (where I view profile and achievements) and google play services, none of it worked. 
  I decided to reset my Galaxy tab s6 completely back to factory settings installed the game again but still wouldn’t log me into profile it just had the choose account box and still didn’t work. 
       I tried the game again and the hi there pop up for my profile popped up. It now seems to log me in to my profile but I don’t always get the ‘hi there’ profile notification as when I get this I will get an achievement pop up aswell in game although this has only Happened the once out of 5 achievements I have earned so far. 
     So at the moment it seems I’m getting achievements but not always the pop up, also when I look at profile it says sometimes 5/5 achievements unlocked instead of 5 out of the 94 available in game.  
       Sorry about long reply but trying to give as much info as possible so can be fixed as seems to definitely be a bug with the game, not having issues with other games popping achievements. 
     Thanks,please keep me informed of any progress the dev team makes on the issue
 

Link to post
Share on other sites
  • 5 weeks later...

I also had this issue. In my case I downloaded the game initially on a different device to the one im playing onnow. I think you can only sign into the game on one device through Google Play

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...