Jump to content

Graphic packs wont work on Macbook pro.


Recommended Posts

Graphic packs "bug" on mac?

So guys i have tried for hours to "install" graphic to fm20 on my mac, and well i am furious because i am not able to do so.. For all these years that has not been a problem. I have followed every step by step guide, i have tried to use the graphics i used in fm19 did not work tried to download new graphic, still did not work..

​

I will show a ss and as you can see i choose clear cache but it just stays on reset? I have also ticked off the other correct boxes as you can see. On earlier fm´s when you choosed clear cache and hit confirm there wold appear a info box where you had to hit ok and it would load for a while and graphics would appear. Pressing clear cache here just throws be right back in the game... so help would be much appreciated:)

Yes i am aware that on mac this year the fm folder is hidden in the library, but i have already moved it to the correct folders. or is the problem i moved everything from library to the SI folder in documents while i should only moved the graphics pack to the "normal" documents folder?

I will try to upload the ss later today when i get home. 

Link to post
Share on other sites
vor 1 Stunde schrieb Llainen:

Graphic packs "bug" on mac?

So guys i have tried for hours to "install" graphic to fm20 on my mac, and well i am furious because i am not able to do so.. For all these years that has not been a problem. I have followed every step by step guide, i have tried to use the graphics i used in fm19 did not work tried to download new graphic, still did not work..

The directory has changed for FM 2020 on macs. You need to move the graphics folder in the same directory where you can find the cache and preferences folders.

Link to post
Share on other sites

@Llainen,  there's been a substantial change to how Mac FM20 documents are stored. Previously the files would automatically go in the Documents folder here:

Users/YOUR Mac USERNAME/Documents/Sports Interactive 

Now the files will instead appear in the following location:

Users/YOUR Mac USERNAME/Library/Application Support/Sports Interactive

By default this folder is hidden, so to access you need to do as follows:

Open Finder
Click ‘Go’ from the menubar
Press and hold down the ‘Option’ (Alt) key
This will bring up the ‘Library’, click to enter then go to ‘Application Support’ -> ‘Sports Interactive’ -> ‘Football Manager 2020’

 

Hope this helps :thup:

Link to post
Share on other sites
15 minutes ago, Mons said:

@Llainen,  there's been a substantial change to how Mac FM20 documents are stored. Previously the files would automatically go in the Documents folder here:

Users/YOUR Mac USERNAME/Documents/Sports Interactive 

Now the files will instead appear in the following location:

Users/YOUR Mac USERNAME/Library/Application Support/Sports Interactive

By default this folder is hidden, so to access you need to do as follows:

Open Finder
Click ‘Go’ from the menubar
Press and hold down the ‘Option’ (Alt) key
This will bring up the ‘Library’, click to enter then go to ‘Application Support’ -> ‘Sports Interactive’ -> ‘Football Manager 2020’

 

Hope this helps :thup:

I moved all this to the «normal» documents folder. Maybe thats the problem? Just keep everything in the library?:)

 

thanks!

Link to post
Share on other sites
1 hour ago, Llainen said:

I moved all this to the «normal» documents folder. Maybe thats the problem? Just keep everything in the library?:)

 

thanks!

Looks like it. As described, if you're on a Mac, putting custom data (editor data, graphics and/or skins) in the "normal" Documents folder won't work.

Link to post
Share on other sites
22 minutes ago, Mons said:

Looks like it. As described, if you're on a Mac, putting custom data (editor data, graphics and/or skins) in the "normal" Documents folder won't work.

Ok, thanks again. Will try it when i get back home:)

Link to post
Share on other sites
4 hours ago, Mons said:

@Llainen,  there's been a substantial change to how Mac FM20 documents are stored. Previously the files would automatically go in the Documents folder here:

Users/YOUR Mac USERNAME/Documents/Sports Interactive 

Now the files will instead appear in the following location:

Users/YOUR Mac USERNAME/Library/Application Support/Sports Interactive

By default this folder is hidden, so to access you need to do as follows:

Open Finder
Click ‘Go’ from the menubar
Press and hold down the ‘Option’ (Alt) key
This will bring up the ‘Library’, click to enter then go to ‘Application Support’ -> ‘Sports Interactive’ -> ‘Football Manager 2020’

 

Hope this helps :thup:

i cannot thank you enough mate! Stupid me, i should not have moved everything from library to documents, Just kept it in the library and made a graphics map there.. XD. Have a wonderful weekend and enjoy the game:)

Edited by Llainen
Link to post
Share on other sites
1 minute ago, Llainen said:

i cannot thank you enough mate! Stupid me, i should not have moved everything from library to documents, Just kept it in the library and made a graphics map there.. XD. Have a wonderful weekend and enjoy the game:)

Welcome - same to you and happy to have helped :thup:

Link to post
Share on other sites
13 minutes ago, andyhome99 said:

Hi I have had the same issue, I have now moved a graphics folder into the right location but it still hasn't worked in the game itself? What am I doing wrong?

Have you changed your preferences to this?

https://i.imgur.com/0yPuoXt.png

Also, try changing the skin to force the cache to reload and maybe display the graphics.

Link to post
Share on other sites
vor 8 Minuten schrieb andyhome99:

Yeah I have tried both with and without reloading a skin but still no change...

Try to change the skin and then go back to your favored skin.

Link to post
Share on other sites
22 minutes ago, andyhome99 said:

Perfect! Thank You - Will these be here once the full version is released?

Do you get your facepack to work? Everything logo/kits works with me now but not the facepacks.. maybe should try changing the skin 

Link to post
Share on other sites

Hi, I'm having problems getting it to work correctly.

I've downloaded a badge mega pack, and the premier league kits, extracted the files, and within the new file route i've created "Graphics" and then "kits", "logos" and "faces". 

I've followed the preferences from the above FM20 screenshot, and it's not loading the graphics into the game - any ideas why it's not playing ball?

I've reloaded and changed the skin multiple times but it's not had any effect :(

Edited by Chris1803
Link to post
Share on other sites
vor 38 Minuten schrieb Chris1803:

Hi, I'm having problems getting it to work correctly.

I've downloaded a badge mega pack, and the premier league kits, extracted the files, and within the new file route i've created "Graphics" and then "kits", "logos" and "faces". 

I've followed the preferences from the above FM20 screenshot, and it's not loading the graphics into the game - any ideas why it's not playing ball?

Changing and re-changing the skin could help, as there is a problem with reloading the skin.

Link to post
Share on other sites
39 minutes ago, KUBI said:

Changing and re-changing the skin could help, as there is a problem with reloading the skin.

I've reloaded the skin what feels like hundreds of times, and so far it's had no impact at all. I'm wondering if there's something I've missed or have a problem with? 

Link to post
Share on other sites
vor 1 Minute schrieb Chris1803:

I've reloaded the skin what feels like hundreds of times, and so far it's had no impact at all. I'm wondering if there's something I've missed or have a problem with? 

Did you move the graphics to the new directory? It's not the same as for FM 2019. 

Link to post
Share on other sites
22 minutes ago, KUBI said:

Did you move the graphics to the new directory? It's not the same as for FM 2019. 

I thought I had, but actually no... because I'd been right clicking on FM20 within steam, and going to browse local files (thinking I was seeing what I needed to, to view the files), I was placing them in the wrong folder. It's only going back through the trail now that I've spotted my catastrophic balls up and that I hadn't been in the right place all along. 

Will leave this humiliation here in the hope others won't make the same mistake I have. If I'd have checked the file thread I could have spotted my mistake earlier.

Thanks for inadvertently helping me spot the error!

 

Edited by Chris1803
Link to post
Share on other sites

I've changed the location setting ("choose the location to save all your files to") to a new FM20 folder I created in my Documents folder. Put all graphics there (in a subfolder) just as with FM19 and before. That way you don't have to search deep in the Library folder.

Link to post
Share on other sites
On 02/11/2019 at 06:50, blue heron said:

I've changed the location setting ("choose the location to save all your files to") to a new FM20 folder I created in my Documents folder. Put all graphics there (in a subfolder) just as with FM19 and before. That way you don't have to search deep in the Library folder.

Yesterday I had to reinstall after the 20.0.2 update - I couldn't select another location. But it works again now,

Link to post
Share on other sites
  • 4 weeks later...

By default, it's under your Library folder in your user's home directory. If you can't see this in Finder, you can use the "Go" menu, see screenshot below:

 

image.thumb.png.94f654b75501d182c0ec514023a4d370.png

 

By default you should look in Library / Application Support / Sports Interactive / Football Manager 2020

Link to post
Share on other sites
  • 2 weeks later...

Hey guys,

I'm having an issue with loading the logos. I've downloaded the megapack, found all the folders in my library, had to create a graphics folder and put the megapack in there, changed the preferences to all the correct ones, reloaded and changed the skins multiple times and still nothing! I'm sure i'm missing something but if you guys could let me know where i've gone wrong I would really appreciate that! 

Thanks a lot!

 

 

Screen Shot 2019-12-07 at 16.10.49.png

Screen Shot 2019-12-07 at 16.16.00.png

Screen Shot 2019-12-07 at 16.16.19.png

Screen Shot 2019-12-07 at 16.17.32.png

Link to post
Share on other sites

Ok basically the best way of doing it is this, and I use an iMac and a MacBook pro. 

1. You want to create a shortcut to library on Finder

2. You want to give access to folders outside Application Support.  So go to Library>Preferences>File Access> Choose FM20 exe file ( which is in Library>Application Support)

3. Once that is done its fairly easy and straightforward, just put skins/graphics in Documents/SI/Football Manager2020/into the relevant subfolders. 

This gives me way better control of big assets that need to be reused/deleted in the future that can take up a lot of space. 

If you still aren't clear just go google "giving file access to applications on Mojave/Catalina"

 

Link to post
Share on other sites

Unrelated to the topic except that I'm using a MacBook Pro as well. Posted a thread on this but to no avail. Though I'd give it a shot here.

 

I want to delete a folder as seen below but delete option is not clickable, what should I do?

 

Thank you.

6 hours ago, brendonang said:

Still not working, unfortunately.

 

I searched Sports Interactive⁩ ▸ ⁨Football Manager 2020⁩ ▸ ⁨games⁩ 

 

Only to find config.xml, which I can't open. Just to clear things up, I want to delete a folder and not a saved game as I accidentally created a new folder which is of no use to me.

As you can see in the screenshot provided, the delete option is not clickable :(

 

Screen Shot 2019-12-08 at 12.34.55 am.png

 

Link to post
Share on other sites

I'm having more or less the same problem with graphics on my MacBook Pro (Catalina) on FM19. Here's where I'm saving them (/Users/myname/Library/Application Support/Sports Interactive/Football Manager 2019/graphics). I'm still not able to load these graphics in game (despite doing the whole clear cache/page loading times/reload skin thing).

 

Is this the correct place for these files? Am I doing something wrong? I've tried restarting, reinstalling, saving the folders under the old pathway (/Users/myname/Documents/Games/Sports Interactive/Football Manager 2019/graphics), but nothing is working. Scratching my head here.

1655760490_Screenshot2019-12-07at20_30_53.thumb.png.3b8536d3ae36791b634789421e1a3710.png

Link to post
Share on other sites
11 hours ago, EdL said:

For FM19 its still the old location in your documents folder then "Sports Interactive" etc as per abovr

Thank you for the reply!

 

I had tried this location earlier and have moved the files back there, but still no dice. Other than the location and the clear cache/page loading times/reload skin sequence, is there anything else I could be doing wrong?

Link to post
Share on other sites
On 08/12/2019 at 14:31, EdL said:

that should be all thats needed, what is the exact path you are putting them in?

Macintosh HD/Users/myname/Documents/Sports Interactive/Football Manager 2019/graphics

 

I had to create the graphics folder myself. I then have the packs as subfolders within graphics, each subfolder is just the png image collection and the config file.

 

Does this sound right?

Link to post
Share on other sites
23 minutes ago, josh994 said:

Macintosh HD/Users/myname/Documents/Sports Interactive/Football Manager 2019/graphics

 

I had to create the graphics folder myself. I then have the packs as subfolders within graphics, each subfolder is just the png image collection and the config file.

 

Does this sound right?

Nope. Read this post of mine from last month :thup:

Link to post
Share on other sites
vor 26 Minuten schrieb josh994:

Macintosh HD/Users/myname/Documents/Sports Interactive/Football Manager 2019/graphics

 

New directory on Macs:

Users/YOUR Mac USERNAME/Library/Application Support/Sports Interactive

By default this folder is hidden, so to access you need to do as follows:

Open Finder

Click ‘Go’ from the menubar

Press and hold down the ‘Option’ (Alt) key

This will bring up the ‘Library’, click to enter then go to ‘Application Support’ -> ‘Sports Interactive’ -> ‘Football Manager 2020’

Link to post
Share on other sites
  • 1 month later...

Hi guys, I always thought I's the only one with that problem. But reading you didn't fix it... 

Can someone telle me why it does not work ? 

I did " ALT + GO " and put the files in, it works for LOGO but not for faces, don't get why ? 

Thanks for your help

Capture d’écran 2020-02-01 à 22.38.32.png

Link to post
Share on other sites

Could be any number of reasons, ie:

  • Faces folder doesn't have a config file
  • There's nothing in the faces folder 
  • The config file(s) are incorrectly written
  • Cache related - delete your skin caches and try again when you relaunch.

I can't really tell from there if there is an issue.

Link to post
Share on other sites

Hi, thanks for answering. 

1. By saying it doesn't have a config file you mean it should be outside the graphics folder ? if yes then I tried and didn't work
2. yes there's somthing (file attached) 
3. which one are incorrectly ? how do I've to write it  ? 

Whats really weird is that everything else work but not that especially one " faces", thanks for your help 

Capture d’écran 2020-02-01 à 23.09.53.png

Link to post
Share on other sites
vor 11 Stunden schrieb LRKABEYA:

Hi, thanks for answering. 

1. By saying it doesn't have a config file you mean it should be outside the graphics folder ? if yes then I tried and didn't work
2. yes there's somthing (file attached) 
3. which one are incorrectly ? how do I've to write it  ? 

Whats really weird is that everything else work but not that especially one " faces", thanks for your help 

The DF 11 Megapack uses large pictures, this is not supported by the default skins. You need to download and install a third party skin that supports the DF11 pictures.

Link to post
Share on other sites

Thanks for replying, what do you mean by a third party skin ? It's strange cause it used to work on every other FM that way. 

I just dragged the "config file" from the DF 11 FM 19 to the actual cause I didn't have it.. does not change a thing. 

Edited by LRKABEYA
Link to post
Share on other sites
vor 17 Stunden schrieb LRKABEYA:

Thanks for replying, what do you mean by a third party skin ? It's strange cause it used to work on every other FM that way. 

I just dragged the "config file" from the DF 11 FM 19 to the actual cause I didn't have it.. does not change a thing. 

Put the folder out of faces, just into the graphics folder. 

Link to post
Share on other sites

Thanks for Replying and helping . Just did that and no change... Can't get it.. while logos and kits work perfectly. 

I am starting to think they don't work on MAC cause other ppl've se same unsolved problem, but that can't be true, has to be a way. 

6 hours ago, KUBI said:

Put the folder out of faces, just into the graphics folder. 

 

Capture d’écran 2020-02-03 à 17.29.47.png

Link to post
Share on other sites

Hey there... download fmxml to create your own config.. it won't matter where you put folders as long as you get the correct config for it...  

 

https://www.fmscout.com/a-fmXML-for-windows.html

 

It shows you how to use it on the link posted...

 

The folder you will obviously want to drag or find in the app is the df11 megapack folder ... click faces.... all file names are id's ... and click go... 

 

Once you do that, go into game, preferences, untick skin cache, reload skin.. should work.. if it doesn't , it is definitely the faces themselves thats the issue.

Link to post
Share on other sites
vor einer Stunde schrieb LRKABEYA:

Thanks for Replying and helping . Just did that and no change... Can't get it.. while logos and kits work perfectly. 

I am starting to think they don't work on MAC cause other ppl've se same unsolved problem, but that can't be true, has to be a way. 

Rename the folder to either AD11 or ZD11 and try it again. Sometimes a package works only when it is loaded first or last.

Link to post
Share on other sites
1 hour ago, Welshace said:

Hey there... download fmxml to create your own config.. it won't matter where you put folders as long as you get the correct config for it...  

 

https://www.fmscout.com/a-fmXML-for-windows.html

 

It shows you how to use it on the link posted...

 

The folder you will obviously want to drag or find in the app is the df11 megapack folder ... click faces.... all file names are id's ... and click go... 

 

Once you do that, go into game, preferences, untick skin cache, reload skin.. should work.. if it doesn't , it is definitely the faces themselves thats the issue.

It's a link for windows and i use Mac unfortunately, I tried but doesn't seem to work on my computer : ( 

Link to post
Share on other sites
4 hours ago, KUBI said:

Rename the folder to either AD11 or ZD11 and try it again. Sometimes a package works only when it is loaded first or last.

Did that and guess what ? No change. I am sick of it. I thought maybe something was not right in " the interface"... 

I don't know what to try .. Thank you lots for your comments and help, I appreciate. 

Some ppl on that groupe got the same problem and still unsolved 

 

Capture d’écran 2020-02-03 à 23.04.12.png

Capture d’écran 2020-02-03 à 23.04.40.png

Link to post
Share on other sites
  • 10 months later...
vor 7 Minuten schrieb JNeves2001:

What about FM21? Everything is working except the facepack, can anyone help me?

 

This thread was started when they did change the directory for graphic packs. They work on FM21 as usual. If you have problems to load it, check if there are other facepacks in your graphic folder and remove them.

Link to post
Share on other sites
  • KUBI locked this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...