If you're running on Nvidia drivers, please try the following steps to see if it improves your issue: - Right-click on your desktop - Open Nvidia Control Panel - Click 'Manage 3D settings' - Select 'Program Settings' - From the 'Select a program to customise, click the dropdown and select 18 Football Manager (FM.exe) - Click on this to select it - Now within the options, scroll down to where it says 'Vertical Sync' - Click on it and select 'Fast' - Click 'Apply' If that