+ Reply to Thread
Results 1 to 4 of 4

Thread: Issue loading game (even after reboot)

  1. #1

    Default Issue loading game (even after reboot)

    Hello,

    Installed and started playing FMH on my SGS2 yesterday. This morning upon exiting the game, it crashed and caused a reboot. Now when I attempt to load my game (icon: Continue game), it very briefly flashes with 'Restoring Game data' and returns to the main menu.

    *During the process of writing this post, I just wanted to check my facts and started a new game to see if that works. It did, but now all my old saved games have disappeared. On my latest attempt at running the game, it prompted me to download files once again (as it did on first installation), so I'm really not sure what has happened here... but my saved games are gone. - Interestingly, the icon has since changed from 'Continue Game' to 'Load Game'*

    At no point have I had my phone running in USB storage mode on my machine.

    In: fmh_data\save_games , the only files present are the ones I have just created when testing by starting a new game.

    I don't really have much hope of getting my saved game back, but I just thought I should start this thread to register it as a possible bug. If there are any log files/further information I can provide, I will happily provide it.

    Samsung Galaxy S2
    Running: 2.3.4
    Free space: over 2gb on the internal 'sd card'

    Cheers

  2. #2
    Sports Interactive Alari Naylor's Avatar
    Join Date
    16th September 2011
    Location
    Old Street, London
    Posts
    2,289

    Default

    Hi,

    Thanks for reporting this and sorry you've experienced the issue.

    It sounds like the original problem was that the game crashing on exit caused the autosave to corrupt, which is what was causing the game to return to the main menu when you were trying to load. However, there should have been a backup autosave (the game works on a weekly rolling autosave system) and it's a bit puzzling if that has disappeared.

    Can I just check, had you saved the game into the manual save slots at all before you experienced this?

  3. #3

    Default

    I had indeed. Saved one manual slot (that I did before exiting the game each time) and just left the autosave to do its thing.

    It looks like a hard one to diagnose, I wish I hadn't mucked about so much before reporting the issue as it would have been more helpful. It almost reads like a local storage issue on the phone itself, or maybe it was caused by the mysterious invocation of the initial data download once I rebooted a few times.

    I'm going to start a new game and will report back if it occurs again, I wasn't too far through the season (and was doing rubbish) so I'm not too upset. I'll do my own incremental backups to make sure I don't lose everything.

    Cheers

  4. #4
    Sports Interactive Alari Naylor's Avatar
    Join Date
    16th September 2011
    Location
    Old Street, London
    Posts
    2,289

    Default

    If it deleted your manual save, that's really bizarre!

    The only thing I can imagine is that your original data download was incomplete/corrupt, which caused the app to get confused when starting it back up again. Do let me know if it happens again, and of course we'll keep a very careful eye out for it here.

    Edit: Just to let you know we've now had a couple of further reports of people experiencing what sounds like a similar issue on the SGS2, so we're actively investigating the cause.
    Last edited by Alari Naylor; 13-04-2012 at 12:04.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts