PDA

View Full Version : Please Help - Windowed Mode



QPRbrad
23-01-2009, 17:54
It seems to be one problem to the next for me with this!

I got FM 09 up and running and everything was going great, but then my first friendly came and I went to the match and it said setting up game... and then an error popped up saying something serious had happened with crash dumps or something and the application has to be closed. And i've realised a lot of people have had this problem and have to play in windowed mode. But when I go into preferences to change to windowed mode it is greyed out. So I then added the bit onto the end of the target in the shortcut and I click on the shortcut but it still opens up Steam and I have to launch the game via Steam, but I was wondering will this still play FM 09 in full screen or windowed mode? Or when you click on the shortcut with the windowed mode bit at the end of the target it goes straight into the game? Have I done something wrong?

jod123
23-01-2009, 18:11
What have you in the target?

QPRbrad
23-01-2009, 18:34
Well i can't remember the first bit cos its on my other computer but I know it's something like programs/steam" -windowed small_screen

jod123
23-01-2009, 18:37
Well try going to C:\Program Files\Steam\SteamApps\common\football manager 2009 and then right click on the fm.exe file in there and choose copy. Then right click on a blank place on your desktop and choose paste shortcut. Then use that shortcut to try and enable windowed mode by editing the target in that by adding -windowed small_screen. Let me know if it works. You also won't need to have Steam running at all then when playing the game.

QPRbrad
23-01-2009, 18:44
That's what I did, but it opens up steam and so i'd have to click on FM 09 and launch it from Steam, is this right?

jod123
23-01-2009, 18:47
If you create the shortcut like I said then steam should have nothing to do with it. Basically if you use that shortcut then you do not have to use steam at all.

QPRbrad
23-01-2009, 18:50
Is there nothing I could put in the target instead? The thing is im playing FM 09 on my brothers computer and he dont want me playing it on there but hes not here a lot of the time so i need the shortcut hidden, not on the desktop so i did it in my documents.

jod123
23-01-2009, 18:55
Is there nothing I could put in the target instead? The thing is im playing FM 09 on my brothers computer and he dont want me playing it on there but hes not here a lot of the time so i need the shortcut hidden, not on the desktop so i did it in my documents.

Does he not go into My Documents? ;)

But anyway you can just do what I said above and instead of pasting it on the desktop just paste it in My Documents or whereever you like. It does not matter where you put it.

A different way to do the same thing is in the target of the shortcut you are currently using just delete everything from it and paste in "C:\Program Files\SteamApps\common\football manager 2009\fm.exe -windowed small_screen". If you installed the game to the default location then that should work.

QPRbrad
23-01-2009, 18:58
Ok jod, cheers for your help, will try later tonight, really appreciate it ;)

jod123
23-01-2009, 19:11
No problem. Let me know if you get it to work. :thup:

QPRbrad
23-01-2009, 20:13
Still don't work, says invalid target. ffs, when the hell am I gonna get this working!!!??? jod, any other ideas mate?

jod123
23-01-2009, 20:17
The best way is just create a new shortcut like I said above and then edit the target of that by just adding on the windowed bit.

QPRbrad
23-01-2009, 20:22
Ok sorry a misunderstanding I get what you meant now, I've created a shortcut for fm.exe, sorry for being a bit dumb I appreciate your help massively! Right it's allowed the target this time... now i'm gonna try it, wish me luck :) ...

jod123
23-01-2009, 20:22
Don't worry. :D

Good Luck. :) :thup:

QPRbrad
23-01-2009, 20:26
Grrrrr, it's still full screen, not windowed mode! Anything else? lol

jod123
23-01-2009, 20:35
Could you tell me exactly what you have in the target?

QPRbrad
23-01-2009, 21:02
This is what's in the target:

"C:\Program Files\Steam\SteamApps\common\football manager 2009\fm.exe" -windowed small_screen

I went into properties and added -windowed small_screen to the target and clicked on ok and it still opens in full screen and i played the game and again it was running fine until i went to match and it goes "setting up game" and then brings down FM 09 and says:

Application Error.

A serious error was encountered and the application will close. An error file has been generated in: D5S5B02J/C:/Documents and Settings/Si/My Documents/Sports Interactive/Football Manager 2009/crash dumps

Oh i've just realised something! Ss it -windowed -small_screen ??? Not -windowed small_screen ??? That's you're fault jod ;) lol i'll try again

QPRbrad
23-01-2009, 21:11
I WAS RIGHT IT WORKED!!! I LOVE YOU JOD YOU'VE SOLVED MY PROBLEMS!!! YOU ARE THE MAN!!!

Hopefully this is the end to all my problems on FM! Will this definitely stop the application closing when i go to a match?

QPRbrad
23-01-2009, 21:17
FFS!!! Windowed mode works but still doesn't let me play the match, same problem!!! FFS!!! What is the problem?!?!?!?!?!?!?!?! Will this be fixed in the next patch??!?!!? This is absolutely p.issing me the hell off now, it's a joke!

jod123
23-01-2009, 22:26
Glad you got windowed mode working but it will not fix all errors obviously. I assume you got the the 9.2.0 patch?

QPRbrad
24-01-2009, 19:32
Sorry it does work, thanks jod lol, I can play happily now, all I did was turned off 3D matches and it works fine on 2D, thanks alot, no more problems :D

jod123
24-01-2009, 19:50
Glad it finally works. :) Although you obviously cannot use 3D though.