PDA

View Full Version : Cannot purchase from Google play store



SnakeXe
13-05-2012, 11:09
Hi, tried to purchase the game from the Google play store on my Transformer Prime and its saying I cant purchase the game in my country. I was in Karlsruhe last week for a conference but am back in the UK now so don't know whether that would affect it?

Marc Vaughan
13-05-2012, 15:33
Did you purchase the device in that country or create the google account while there?

SnakeXe
13-05-2012, 16:08
No to both. The only thing I can think of is I downloaded one app whilst there, would that relocate it or something? I've downloaded a couple since returning though so I wouldn't have thought so...

Marc Vaughan
13-05-2012, 16:17
Try clearing the store cache and see if that helps fix the situation, does sound very unusual - not something I've heard of before.

SnakeXe
13-05-2012, 17:19
Clearing cache did not help so I have raised it with Google's support system, I'll keep this thread updated with any solution that is forthcoming, in case anyone has the same problem.

SnakeXe
13-05-2012, 18:28
Ok Google want me to do a factory reset. Given the amount of time I've spent setting things up the way I like it - and I only purchased it recently - this is quite a slap in the face to be honest.

I might just stick to the PC version.

SnakeXe
14-05-2012, 11:23
Creating a new Google account and buying through that fixed it. I think that shows it's a problem with the fact that I was either signed in in Germany, or downloaded an app in Germany.

Alari Naylor
14-05-2012, 11:25
Thanks for that, it's good to know there's an easy way to solve it if anyone experiences the same issue.

SnakeXe
14-05-2012, 11:28
No problem :thup: