PDA

View Full Version : Windows 7 stuttering 3D matchs



reillyg
25-11-2009, 22:35
I was playing FM10 on Windows Vista and it was fine the 3D games were running really smoothly. But I have just upgraded to Windows 7 and now the games stutter and jump. :(

Does anyone have any ideas why this might be happening?

Thanks

Tez01979
25-11-2009, 23:45
Are you running anything in the background and are you usig 32 bit or 64 bit windows?

trekman
25-11-2009, 23:48
Whats the spec of your computer (graphics card and amount of ram?). Make sure that you have the windows7 drivers for your graphics card which you should be able to get from the manufacturer of your card. I had a similar problem and found that turning off crowds and stadiums helped.

tjb2376
25-11-2009, 23:51
Whats the spec of your computer (graphics card and amount of ram?). Make sure that you have the windows7 drivers for your graphics card which you should be able to get from the manufacturer of your card. I had a similar problem and found that turning off crowds and stadiums helped.

AlacrityPC. F'ing BRILLIANT!

My laptop is a bit old. It really helps. Cuts off all unnecessary PC processes. Just leaves those needed for the game. It's a lifesaver, for me!

http://alacritypc.kensalter.com/

(I am NOT on commission!)

Tez01979
25-11-2009, 23:54
no real need to turn off crowds unless your computer is really slow - i run mine a duel core 2 Ghz with 64 bit win and 2GB Ram and get no problems. Sometimes the ME starts stuttering if i have things in the background running like firefox

I reckon this is due to what many ppl think is a memory leak that is in the game - hence all the crash dumps + if things were running in the background it's using memory as well so makes sense to me.

fonejacker
25-11-2009, 23:55
iobit game booster seems to do the trick for me. As well as the turning off crowds and stadiums, as previously mentioned.

FJ.

reillyg
26-11-2009, 01:19
It 64 bit windows 7

My computer's specs are:
500GB hard drive (300GB free)
4GB ram
Dual Core 2ghz
ATI Mobility Radeon HD 4330

I think I got all the drivers for the graphics card, but I will check again.

Tez01979
26-11-2009, 01:24
It 64 bit windows 7

My computer's specs are:
500GB hard drive (300GB free)
4GB ram
Dual Core 2ghz
ATI Mobility Radeon HD 4330

I think I got all the drivers for the graphics card, but I will check again.


Again are you running anything in the background like firefox etc. This can have a big impact - also does stuttering happen all the time or just sometimes?

reillyg
26-11-2009, 01:29
Again are you running anything in the background like firefox etc. This can have a big impact - also does stuttering happen all the time or just sometimes?

Sorry, yeah I always have firefox open, but I had firefox open in Vista and it was smooth. The stuttering is mostly the ball and it gets worse when you increase the match speed and overall its just not smooth, I can make out whats happening, just, but its not nice to watch.

I am downloading the driver for my grapics card, I think I already have it but it might do the trick.

Tez01979
26-11-2009, 01:40
Sorry, yeah I always have firefox open, but I had firefox open in Vista and it was smooth. The stuttering is mostly the ball and it gets worse when you increase the match speed and overall its just not smooth, I can make out whats happening, just, but its not nice to watch.

I am downloading the driver for my grapics card, I think I already have it but it might do the trick.

I think its a common thing with win 7 as your not the first to get it. However i only get the issue when firefox is open but the stuttering isn't consistintly happening all the time. For me usually is a good indicator a crash dump is about tto happen so i save the game and restart

Your comp isn't too much different than mine the only diff being i'm running a radeon 1650 and 2GB less ram so not entirly sure why this is happening consistantly with you but not with me.

The graphic driver should fix it but if not - try closing firefox down for a while, play in full screen or like other posters said (as lasr resort) switch off crowds and stasiums - i wouldn't personally but this may solve the issue

reillyg
26-11-2009, 02:26
I've managed to fix the problem. I downloaded the driver but it didnt make any difference, so I was just fiddleing around with my dispaly setting for my laptop and Windows 7 had reset my frame rate from 60hz to 59hz, so I changed it back to 60hz and its smooth again.

Thanks for all the help and suggestions.

Whirlwind
26-11-2009, 06:39
Everything bloody stutters on Windows 7.

stevio11
26-11-2009, 10:58
no it does not

Tombcfc10
26-11-2009, 11:45
When i try and change mine to 60hz from 59, as i soon as i go off it and back agen it has reset back to 59Hz? lol not sure why

trekman
26-11-2009, 13:54
AlacrityPC. F'ing BRILLIANT!

My laptop is a bit old. It really helps. Cuts off all unnecessary PC processes. Just leaves those needed for the game. It's a lifesaver, for me!

http://alacritypc.kensalter.com/

(I am NOT on commission!)

I use game booster and it does pretty much the same thing.
http://www.iobit.com/gamebooster.html

I'm not on commission either! ;)